No announcement yet.

No IMAP write access on Reply

  • Filter
  • Time
  • Show
Clear All
new posts

  • No IMAP write access on Reply

    Hi ladys and guys

    I have a disgusting issue in our new OXSE installation:
    I can write new mails, they will send out and stored in the "send" folder.
    But if I reply a Mail, the reply will send out but not stored in the imap folder.
    The mail-window stays open and gives this error-message:
    21/07/2009 11:13-->Error: No write access to IMAP folder INBOX (IMAP-2010, 248971073-20)
    but in the mail.log shows no error (for me)

    Could this be in relation to a "replyed flag" in IMAP or something of this ?

    the same in german:

    Ich habe ein ganz komisches Problem mit unser neuen OXSE Installation:
    Ich kann neue Mails schreiben, die verschickt werden und dann im "Gesendet" Ordner gespeichert werden.
    Wenn ich aber eine Antwort schreibe, wird die Mail zwar verschickt, aber die Antwort kann nicht gespeichert werden.
    Das Mail-Fenster bleibt offen und gibt dann folgende Fehlermeldung:
    21.07.2009 11:04-->Fehlermeldung: Kein Schreibzugriff auf IMAP-Ordner INBOX (IMAP-2010, 248971073-15)
    in der mail.log erscheint aber keine für mich sichtbare Fehlermeldung.

    Hat das evtl irgendwas mit irgendwelchen "Gesendet" Makierungen in IMAP - Ordnerstruktur zu tun ?

    Vielen Dank
    Stefan Hefner
    Last edited by Stefan Hefner; 07-21-2009, 11:23 AM.

  • #2
    Hi Stefan,

    i'll anwer in english to allow international users to follow the conversation. What IMAP Server is used at the backend? Has there been any "special" configuration? I use cyrus, dovecot and courier pretty often and this one did not occur yet. What OX Version are you using?



    • #3
      Hi !
      Thank you for answer, its a debian with cyrus + latest OX6 SE
      Sorry I solved the problem after i wrote this question ... it was some kind of .... stupidity of me ... in future i should first think than write

      The story :

      Its the first user (test.user) on this server, so i coudnt crosstest, if the error appears in other mailboxes. I created another testuser and there was no problem. So the issue was not in OX
      Then i remembered that I destroyed (to test what's happen) the INBOX last week directly after creation on the filesystem (I deleted all files in the directory), but restored it with "cyrreconstrution". It seems it recreates the Mailbox but not the rights of the owner.
      So the user had enough rights to see the INBOX, but not to write in it.
      With "cyradm" I gave the user its rights back, and the issue was solved

      Thank you !!!