Announcement

Collapse
No announcement yet.

Can't create context (RMI class loader disabled)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can't create context (RMI class loader disabled)

    Hi Guys.

    I searched with google and in this forum. Still found no solution for my problem.

    I think it's just something to enable somewhere, somehow. I have absolutely no knowledge about java.

    I got these error message:

    Code:
    [root@www ~]# createcontext -A oxadminmaster -P pass_word -c 1 -u oxadmin -d "Context Admin" -g Admin -s User -p pass_word2 -L defaultcontext -e postmaster@domain.tld -q 1024 --access-combination-name=all
    
    context 1 could not be created: 
    Server response:
     Error unmarshaling return; nested exception is: 
            java.lang.ClassNotFoundException: com.mysql.jdbc.exceptions.MySQLSyntaxErrorException (no security manager: RMI class loader disabled)
    It would be great if someone could help me

    btw: i followed the step-by-step installation guide for centos5 in OXpedia.

    Thank you in advance

    aedi.

  • #2
    I noticed that the packets are very new.

    I tried to install OX on my debian lenny system. It finished with the same error.

    Strange, it's the same error and it looks like an error in a script file.
    please correct me if I am wrong.

    tail from /var/log/open-xchange/open-xchange-admin.log.0
    Code:
    Jul 28, 2009 8:51:01 AM com.openexchange.admin.tools.PropertyHandler getProp
    SEVERE: Property 'NEW_CONTEXT_DEFAULT_ACCESS_COMBINATION_NAME' not found in file /opt/open-xchange/etc/admindaemon! Using fallback :NOT_DEFINED
    Jul 28, 2009 8:51:01 AM com.openexchange.admin.storage.mysqlStorage.OXUtilMySQLStorageCommon createDatabase
    SEVERE: SQL Error
    com.mysql.jdbc.exceptions.MySQLSyntaxErrorException: Access denied for user 'openexchange'@'localhost' to database 'ox_8'
    i know there is access to the db.
    what's about the text in bold?

    greets
    aedi
    Last edited by aedi; 07-28-2009, 10:51 AM.

    Comment


    • #3
      Hi,

      what version of OX did you install? According to the error messages, the configured user cannot access the database, maybe some glitch when creating the database? The bold text is just a warning but not related to the problem, the real issue is:
      Code:
      com.mysql.jdbc.exceptions.MySQLSyntaxErrorException: Access denied for user 'openexchange'@'localhost' to database 'ox_8'
      Greetings

      Comment


      • #4
        thanks for ur answer.

        i've istalled version 6.10.0.0-6_6.1

        per commandline, i get access to the mysql db's (ox and configdb)

        the db for OX i want to use is called 'ox'. everytime i try the command createcontext, the error message increases with the number behind the searched db (in my tail i posted i'ts 'ox_8', with the next try it's 'ox_9' and so on).

        where is the config file where i can say what db he has to use?

        sorry for my bad english i hope you understand me

        Comment


        • #5
          OH OH!! Bad fault!

          I found it.

          I created the database ox first, befor i type in 'createcontext'. He tried to create the database 'ox_*', because the origin database is existing and empty.
          I granted him access to database ox_13, and see, it worked.

          bad fault :/

          edit:
          that didn't work too. i tried a createcontext without an existing db, just the grant all rights for the db user.
          he still tried to create a db called ox_6. i granted rights on db ox_7 and then it worked.
          Last edited by aedi; 07-28-2009, 02:31 PM.

          Comment


          • #6
            i don't get it. i can't get it to work. can you spell it out to me what you are doing. please. step by step

            i also just need to do the second last step of the installation with createcontext.

            i use ubuntu 9.04

            Comment


            • #7
              Just thought I'd share the solution, if someone else has this problem.

              The error occurs because your 'openexchange'-mysql-user doesn't have the privileges to create the necessary database for your context.

              Login as your mysql root user and run:
              Code:
              use mysql;
              
              insert into db (Host, Db, User, Select_priv, Insert_priv, Update_priv,Delete_priv,Create_priv,Drop_priv,Grant_priv,References_priv,Index_priv,Alter_priv,Create_tmp_table_priv,Lock_tables_priv,Create_view_priv,Show_view_priv ,Create_routine_priv,Alter_routine_priv,Execute_priv) values ('localhost', '%', 'openexchange', 'y','y','y','y','y','y','n','y','y','y','y','y','y','y','y','y','y');
              
              flush privileges;
              Note, however, that this virtually gives the 'openexchange'-user full access to your database server, which may not always be what you want.

              Good luck,
              /coa [..@..] respondify.se

              Comment

              Working...
              X