Announcement

Collapse
No announcement yet.

Java6 and Debian Etch

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Java6 and Debian Etch

    Hi,



    I have a problem with java.

    I need install Open XChange on Debian Etch. But before i need java.

    the package sun-java5-jre didn't work. i dont know why!

    i know that java 5 is now EOSL:

    http://www.infoq.com/news/2009/11/java5_eosl

    So i used sun-java6-jre.

    But with following the install guide for Debian Etch,

    i always cannot continue configure open xchange because he cannot find java



    Code:
    update-alternatives --config java
    
    Il y a 3 alternatives fournissant « java ».
    
      Sélection    Alternative
    -----------------------------------------------
              1    /usr/bin/gij-wrapper-4.1
     +        2    /usr/lib/jvm/java-6-sun/jre/bin/java
    *         3    /usr/lib/jvm/java-1.5.0-sun/jre/bin/java

    In fact it is a problem with java, but i want to know if we can use java6 with Etch or it is necessarily to have java5 for Etch.

    Else, i need upgrade my Etch in Lenny. Not kewl :/

    Greetings,


    Baris

  • #2
    Just follow the guide(s):

    http://www.open-xchange.com/oxpedia#OXHESECommercial

    Comment


    • #3
      i 'm looking these guides.

      It is strange. I choose alternative 3 but it didn't work.

      Code:
      # update-alternatives --config java
      
      Il y a 3 alternatives fournissant « java ».
      
        Sélection    Alternative
      -----------------------------------------------
                1    /usr/bin/gij-wrapper-4.1
       +        2    /usr/lib/jvm/java-6-sun/jre/bin/java
      *         3    /usr/lib/jvm/java-1.5.0-sun/jre/bin/java
      
      Appuyez sur Entrée pour conserver la valeur par défaut[*] ou choisissez le numéro sélectionné :3
      Utilisation de « /usr/lib/jvm/java-1.5.0-sun/jre/bin/java » pour fournir « java ».
      
       # java -version
      java version "1.4.2"
      gij (GNU libgcj) version 4.1.2 20061115 (prerelease) (Debian 4.1.1-20)
      
      Copyright (C) 2006 Free Software Foundation, Inc.
      This is free software; see the source for copying conditions.  There is NO
      warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

      Comment


      • #4
        Have you tried uninstalling GCJ? Seems to be some spooky stuff with update-alternatives.

        Greetings

        Comment


        • #5
          i tried, but when i did update-alternatives --config java and chose sun java and then java -version , he found nothing

          Comment


          • #6
            omg i think update-alternatives is dead !!!

            i install manually java following this guide:

            Code:
            wget http://javadl.sun.com/webapps/download/AutoDL?BundleId=37391
            
            mv jre-6u18* jre-6u18-linux-i586.bin
            
            sudo mv ./jre-6u18-linux-i586.bin /opt/
            
            cd /opt/
            
            chmod +x jre-6u18-linux-i586.bin
            
            sudo ./jre-6u18-linux-i586.bin
            
            sudo ln -fs /opt/jre1.6.0_18/plugin/i386/ns7/libjavaplugin_oji.so /usr/lib/mozilla/plugins/libjavaplugin_oji.so
            
            sudo update-alternatives --install /usr/bin/java java /opt/jre1.6.0_18/bin/java 1
            sudo update-alternatives --config java
            
            sudo rm -fr jre-6u18-linux-i586.bin
            on my alternatives i have jre-6u...

            i chose him but ...

            always gcj on java -version :s

            Comment


            • #7
              Code:
              update-java-alternatives -s java-6-sun in /usr/lib/jvm/
              mode auto didn't work, manually it's work !

              I don't understand all mysteries of Linux >_<

              Comment

              Working...
              X