Announcement

Collapse
No announcement yet.

Out of memory on Debian Etch

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Out of memory on Debian Etch

    Hi everybody,

    Today I tried to update an oxldapsync version following OX update.

    All steps of update was proceeded as planned, but after all when I launch ldapsync manually I get a kernel "Out Of Memory" message.

    When I launch a "top" command, I can see the memory amount decrease fastest until depletion.

    Are someone already encountered this problem, can someone help me about this ?

    Thanks in advance.

    ----

    My conf :

    Open-Xchange v6.16.0 rev4
    OXLdapSync v1.0.1-4
    Perl 5.8.8

    Debian Etch 4.0
    Kernel 2.6.18

    RAM : 4096 Mo

  • #2
    Hi,

    This is the first time I hear there is a memory problem. How many users do you try to import or are in the context?

    Comment


    • #3
      Hi and thanks for response,

      I've got 120 users in all, but this is only update of LDAP Sync tool therefore just one of the users has sustained some changes.

      Thanks

      Comment


      • #4
        still weird. We have context with contexts with 300+ users and no problems. I think the problem could be getting the users list. Could please put a die at the end of the function getOXUserList in lib/OX/User/Helper.pm. If the script does not die there it will be a problem getting the parsing the user list.

        Comment


        • #5
          Thanks a lot for the reply, I'll try this today.

          Thanks again.

          Comment


          • #6
            Hi,

            Today I tried to put a die after the function getOXUserList, but there's nothing happened, but I tried to use the old Helper.pm file (version 1.0.1-1 of oxldapsync) and it works, I expect that some function making a loop causes an kernel OoM.

            Did you think that the solution has good or I need to downgrade to version 1.0.1-1 definitely ?

            Great thanks.

            Comment


            • #7
              I had the same problem with oxldapsync-1.0.1-27.1 on SLES10 SP3.
              I found out that the loop
              while (my $row = $csv->getline ($io))
              in /opt/oxldapsync/lib/OX/User/Helper.pm line 218 is an infinite loop,
              because Text::CSV_XS seems yield empty rows infinitely. This may be a bug in
              perl-Text-CSV_XS-0.23-372.4 (from the SLES 10 SP3 SDK).

              May be the same problem occurs on Debian.

              The problem can be solved by adding

              last if ( ! @fields );

              below my @fields = @$row; (line 220 in lib/OX/User/Helper.pm)

              see also https://bugs.open-xchange.com/show_bug.cgi?id=17045

              Comment


              • #8
                Thanks a lot for your reply, I can't try this for the moment
                but if the problem occur I'll try.

                I'll make a feedback here when I did a test under Debian.

                Thanks again.

                Comment

                Working...
                X