Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Page 1 of 3 123 LastLast
Results 1 to 10 of 24
  1. #1
    gvincent Guest

    Default Problem with start groupware

    Hi,

    I have a problem when I try startup the groupware :

    start-stop-daemon -vvv --chuid open-xchange:open-xchange --start --startas /opt/open-xchange/sbin/open-xchange-groupware --make-pidfile --pidfile /var/run/open-xchange-groupware.pid

    Starting /opt/open-xchange/sbin/open-xchange-groupware...
    start-stop-daemon: Unable to open pidfile `/var/run/open-xchange-groupware.pid' for writing: Permission denied


    Any idea ?
    Thanks for advance.
    Last edited by gvincent; 04-14-2008 at 03:46 PM.

  2. #2
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    why don't you just use the init scripts? /etc/init.d/open-xchange-groupware start/stop should work fine.

    Greetings

  3. #3
    gvincent Guest

    Default

    Because, when I launch

    /etc/init.d/open-xchange-groupware start
    open-xchange-groupware.

    and

    /etc/init.d/open-xchange-groupware status
    Checking for Open-Xchange Groupware: not running

    thanks to reply

  4. #4
    gvincent Guest

    Default

    I test change user and group
    open-xchangepen-xchange
    to
    root:root

    I have no error

  5. #5
    gvincent Guest

    Default

    I read the log after starting with root user and I view this error :

    Code:
    ATTENTION: /opt/open-xchange/etc/groupware/servletConfig does not exist or is not a directory
    14 avr. 2008 15:57:06 com.openexchange.tools.ajp13.AJPv13Config logInfo
    INFO:
    AJP CONFIGURATION:
            AJP_PORT=8009
            AJP_SERVER_THREAD_SIZE=1
            AJP_MAX_NUM_OF_SOCKETS=150
            AJP_MOD_JK=true
            AJP_LISTENER_POOL_SIZE=100
            AJP_LISTENER_READ_TIMEOUT=0
            AJP_CONNECTION_POOL=true
            AJP_CONNECTION_POOL_SIZE=100
            AJP_REQUEST_HANDLER_POOL=true
            AJP_REQUEST_HANDLER_POOL_SIZE=100
            AJP_WATCHER_ENABLED=true
            AJP_WATCHER_PERMISSION=false
            AJP_WATCHER_MAX_RUNNING_TIME=60000
            AJP_WATCHER_FREQUENCY=30000
            SERVLET_POOL_SIZE=100
            AJP_JVM_ROUTE=OX1
            AJP_CHECK_MAGIC_BYTES_STRICT=true
            AJP_SERVLET_CONFIG_DIR=/opt/open-xchange/etc/groupware/servletConfig
            AJP_BIND_ADDR=localhost/127.0.0.1
    14 avr. 2008 15:57:06 com.openexchange.monitoring.AbstractAgent printTrace
    INFO: com.openexchange.monitoring:name=AJPv13ServerThreadsMonitor registered
    14 avr. 2008 15:57:06 com.openexchange.monitoring.AbstractAgent printTrace
    INFO: com.openexchange.monitoring:name=AJPv13ListenerMonitor registered
    14 avr. 2008 15:57:06 Starter <init>
    GRAVE: Initializing the AJP server failed.
    AJP-0021 Category=6 Message=AJP server socket could not be bound to port 8009. Probably another process is already listening on this port. exceptionID=1414622106-1
            at com.openexchange.tools.ajp13.AJPv13Server.<init>(AJPv13Server.java:168)
            at com.openexchange.tools.ajp13.AJPv13Server.startAJPServer(AJPv13Server.java:145)
            at com.openexchange.groupware.BackendServicesInit.initAJP(BackendServicesInit.java:69)
            at Starter.<init>(Starter.java:170)
            at ComfireServer.main(ComfireServer.java:62)
    Caused by: java.net.BindException: Address already in use
            at java.net.PlainSocketImpl.socketBind(Native Method)
            at java.net.PlainSocketImpl.bind(PlainSocketImpl.java:359)
            at java.net.ServerSocket.bind(ServerSocket.java:319)
    I search error on google but I have not solve problem.

  6. #6
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    This error comes up if any other application is listening on port 8009 - such like a second ox groupware or a tomcat application server. I guess you've two groupware processes running allocating the same port.

    Greetings

  7. #7
    gvincent Guest

    Default

    Code:
    /opt/open-xchange/etc/groupware/servletConfig does not exist 
    ...
    AJP_SERVLET_CONFIG_DIR=/opt/open-xchange/etc/groupware/servletConfig
    I don't have this repertory ?!?

    ls -al /opt/open-xchange/etc/groupware/
    Code:
    drwxr-xr-x 3 root root  4096 avr 14 15:41 .
    drwxr-xr-x 4 root root  4096 avr 14 15:03 ..
    -rwxr-xr-x 1 root root  2787 avr 11 17:58 ajp.properties
    -rwxr-xr-x 1 root root   431 avr 11 17:58 attachment.properties
    -rwxr-xr-x 1 root root 13159 avr 11 17:58 cache.ccf
    -rwxr-xr-x 1 root root  1071 avr 11 17:58 calendar.properties
    -rwxr-xr-x 1 root root  2323 avr 14 15:04 configdb.properties
    -rwxr-xr-x 1 root root    34 avr 14 15:05 configjump.properties
    -rwxr-xr-x 1 root root   590 avr 11 17:58 contact.properties
    -rwxr-xr-x 1 root root   267 avr 11 17:58 event.properties
    -rwxr-xr-x 1 root root   456 avr 11 17:58 file-logging.properties
    -rwxr-xr-x 1 root root   606 avr 11 17:58 foldercache.properties
    -rwxr-xr-x 1 root root  1951 avr 11 17:58 HTMLEntities.properties
    -rwxr-xr-x 1 root root  4684 avr 11 17:58 imap.properties
    -rwxr-xr-x 1 root root  3793 avr 11 17:58 importerExporter.xml
    -rwxr-xr-x 1 root root   431 avr 11 17:58 infostore.properties
    -rwxr-xr-x 1 root root 22915 avr 11 17:58 javamail.properties
    -rwxr-xr-x 1 root root 11219 avr 11 17:58 ldap.properties
    -rwxr-xr-x 1 root root  2410 avr 11 17:58 notification.properties
    -rwxr-xr-x 1 root root  5578 avr 14 15:41 oxfunctions.sh
    -rwxr-xr-x 1 root root   213 avr 11 17:58 ox-scriptconf.sh
    -rwxr-xr-x 1 root root   177 avr 11 17:58 participant.properties
    -rwxr-xr-x 1 root root   647 avr 11 17:58 push.properties
    -rwxr-xr-x 1 root root  1558 avr 11 17:58 server.properties
    drwxr-xr-x 2 root root  4096 avr 11 17:58 servletmappings
    -rwxr-xr-x 1 root root  1373 avr 11 17:58 sessiond.properties
    -rwxr-xr-x 1 root root   647 avr 11 17:58 spellcheck.cfg
    -rwxr-xr-x 1 root root  3706 avr 14 15:04 system.properties
    -rwxr-xr-x 1 root root  1268 avr 11 17:58 updatetasks.cfg
    It's normal ?

  8. #8
    gvincent Guest

    Default

    How view the open ports ?
    netstat ?

    Code:
    Proto Recv-Q Send-Q Local Address               Foreign Address             State
    tcp        0      0 localhost.localdomain:39525 localhost.loc:commplex-main ESTABLISHED
    tcp        0      0 localhost.localdomain:smux  localhost.localdomain:41778 ESTABLISHED
    tcp        0      0 localhost.localdomain:41778 localhost.localdomain:smux  ESTABLISHED
    tcp        0      0 localhost.loc:commplex-main localhost.localdomain:39525 ESTABLISHED
    tcp        0      0 gvnew:microsoft-ds          depan56:vfo                 ESTABLISHED
    tcp        0      0 localhost.localdomain:60245 localhost.localdomain:ssh   ESTABLISHED
    tcp        0      0 gvnew:microsoft-ds          brice:1143                  ESTABLISHED
    tcp        0      0 gvnew:telnet                et_abl:jtag-server          ESTABLISHED
    tcp        0      0 gvnew:microsoft-ds          et_abl:cap                  ESTABLISHED
    tcp        0      0 gvnew:telnet                et_abl:etp                  ESTABLISHED
    tcp        0      0 localhost.localdomain:59963 localhost.localdomain:mysql TIME_WAIT
    tcp        0      0 localhost.localdom:distinct localhost.localdomain:54828 TIME_WAIT
    tcp        0      0 localhost.localdomain:ssh   localhost.localdomain:60245 ESTABLISHED
    tcp        0      0 localhost6.localdomai:60458 localhost6.localdomai:59975 TIME_WAIT
    tcp        0      0 gvnew:58494                 gvnew:58119                 TIME_WAIT
    tcp        0      0 gvnew:ssh                   brice:tvnetworkvideo        ESTABLISHED
    tcp        0      0 gvnew:ssh                   brice:netwatcher-mon        ESTABLISHED
    tcp        0     52 gvnew:ssh                   brice:netwatcher-db         ESTABLISHED
    tcp        0      0 gvnew:ssh                   brice:composit-server       ESTABLISHED

  9. #9
    gvincent Guest

    Default

    I test stop tomcat and start open-xchange-groupware and I have not problem in my log !
    But,
    When I test :
    http://your-server/ajax
    I have :
    "Not Found" error page

  10. #10
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Tomcat and the Open-Xchange Groupware MUST NOT run at the same time using the same port (8009) - if you rely on tomcat, just change the port of the Open-Xchange AJP Interface at etc/groupware/ajp.properties and the related apache configuration (workers.properties)

    If /ajax/ gives you a "No servlet bound to path/alias: ajax" it's normal, does /servlet/webdav.version give you anything like "Version:"?

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •