Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 7 of 7
  1. #1
    thyong Guest

    Default createcontext - Connection refused

    Hi,

    I've tried installing OX:CE on CentOS 5 using package installer on my test server with no problem (initially there's a few but somehow it's solved). My problem now is when I try to install it on another test server configuration with Tomcat and JBoss running. The setup following guide from http://www.open-xchange.com/wiki/ind...de_for_CentOS5 was successful up to the point of creating a context:
    Code:
    /opt/open-xchange/sbin/createcontext -c 1 -A oxadminmaster -P password -N defaultcontext -u oxadmin -d "Context Admin" -g Admin -s User -p password -e admin@abc.com -l en_GB -t Asia/Kuala_Lumpur -q 50 --access-combination-name=all
    The error I get from shell is:
    Code:
    context 1 could not be created: 
    Error: Connection refused to host: localhost; nested exception is: 
            java.net.ConnectException: Connection refused
    I've had port conflicts with Tomcat and JBoss initially which I seem to have removed the error messages by modifying the following files:

    '/opt/open-xchange/etc/admindaemon/RMI.properties'
    Code:
    RMI_PORT=61099
    '/opt/open-xchange/etc/groupware/ajp.properties'
    Code:
    AJP_PORT=8609
    '/etc/http/conf.d/proxy_ajp.conf'
    Code:
    ProxyPass /axis2 ajp://127.0.0.1:8609/axis2 smax=0 ttl=60 retry=5
    ProxyPass /ajax ajp://127.0.0.1:8609/ajax smax=0 ttl=60 retry=5
    ProxyPass /servlet ajp://127.0.0.1:8609/servlet smax=0 ttl=60 retry=5
    ProxyPass /infostore ajp://127.0.0.1:8609/infostore smax=0 ttl=60 retry=5
    Then re-starting 'open-xchange-admin', 'open-xchange-groupware', and 'httpd' services.

    Here's the attached log files:
    open-xchange.log.0.zip
    open-xchange-admin.log.0.zip

    I have no problem connecting to DB with mysql command:
    Code:
    mysql -u openxchange -ppassword openxchange
    Reading table information for completion of table and column names
    You can turn off this feature to get a quicker startup with -A
    
    Welcome to the MySQL monitor.  Commands end with ; or \g.
    Your MySQL connection id is 32913
    Server version: 5.0.45 Source distribution
    
    Type 'help;' or '\h' for help. Type '\c' to clear the buffer.
    
    mysql>
    Is there any configuration that I could of have left out that need to be done? Any help would be appreciated.

    Thanks.

  2. #2
    tronn Guest

    Default

    I allso see those error msg, in the installation guide you should restart the admindeamon a couple of time, on my CentOS 5 system, the admin deamon didn't realy terminate, so I had to "kill -9" on the process. So make sure that the admindeamon really terminate, before you try to start it again


    Tronn

  3. #3
    Carsten Hoeger is offline Open-Xchange Professional Services
    Join Date
    Mar 2007
    Posts
    703

    Default

    When I tried to install ox on RHEL5, I figured out, that the problem was a "strange" /etc/hosts where the hostname has been listed behind the 127.0.0.1 address which seem to confuse java.

    I solved that in adding a separate entry

    192.168.XX.YY my.host.name

    and behind the 127.0.0.1 address, there's only "localhost":

    127.0.0.1 localhost

  4. #4
    thyong Guest

    Default

    [Tronn]

    I checked the daemon process and make sure that I re-started it. The problem still remains.

    [Carsten]

    I've alway had separate entry in my '/etc/hosts':
    Code:
    127.0.0.1       localhost.localdomain   localhost
    ::1     localhost6.localdomain6 localhost6
    192.168.xxx.xxx   my.domain.com   my
    So this don't seems to work for me either.

    -----

    Thanks for your suggestions. BTW, could this in anyway contribute to the problem?
    Code:
    nslookup localhost
    Server:         202.188.0.133
    Address:        202.188.0.133#53
    
    Non-authoritative answer:
    Name:   localhost
    Address: 203.106.203.238
    Pinging 'localhost' gives me reply from 127.0.0.1 though.

  5. #5
    Carsten Hoeger is offline Open-Xchange Professional Services
    Join Date
    Mar 2007
    Posts
    703

    Default

    Quote Originally Posted by thyong View Post

    Thanks for your suggestions. BTW, could this in anyway contribute to the problem?
    Code:
    nslookup localhost
    Server:         202.188.0.133
    Address:        202.188.0.133#53
    
    Non-authoritative answer:
    Name:   localhost
    Address: 203.106.203.238
    Yes, that could also be the source of the problem.

  6. #6
    liquidat Guest

    Default

    I have the exact same problem on my CentOS 5 test-install. I checked the hosts entry, restarted the admin properly, and the nslookup returns 127.0.0.1.

    I can reach the mysql port also by telnet, and I must admit that I'm a bit stuck what else I can give a test...

  7. #7

    Default

    Did you also change the RMI port address? If yes, this might be the cause. When changing the RMI port address, you have to tell the command line tools about that. Because the command line tools won't read /opt/open-xchange/etc/admindaemon/RMI.properties as it's only for the daemon.
    You'll have to set the environment variable RMI_HOSTNAME for this. See the parameter --environment for details.

    HTH,

    Dennis

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •