Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 7 of 7
  1. #1
    jerbourq Guest

    Default Problems with infostore

    I'm having problems getting infostore to work with a testuser. Whenever I log into the gui with the testuser and try to upload a file, it just hangs there and does nothing. I don't know what to check to make sure that the configuration is correct.



    ps -aux |grep open-xchange

    root 21637 0.0 0.0 7044 1856 ? S Sep27 0:00 su -s /bin/bash open-xchange -c /opt/open-xchange/sbin/open-xchange-groupware
    111 21638 0.2 2.3 819956 215928 ? Ssl Sep27 22:43 /usr/bin/java -Xms512m -Xmx512m -XX:+UseConcMarkSweepGC -XX:NewSize=256m -XX:MaxNewSize=256m -XX:SurvivorRatio=6 -Djava.awt.headless=true -Dopenexchange.propdir=/opt/open-xchange/etc/groupware -Djava.util.logging.config.file=/opt/open-xchange/etc/groupware/file-logging.properties -jar /opt/open-xchange/bundles/org.eclipse.osgi_3.3.0.v20070530.jar -configuration file:/opt/open-xchange/etc/groupware/osgi
    root 9485 0.1 1.0 332432 96272 ? Sl Oct01 4:04 /usr/bin/java -Xms100m -Xmx100m -XX:+UseConcMarkSweepGC -XX:NewSize=50m -XX:MaxNewSize=50m -XX:SurvivorRatio=6 -Dopenexchange.propdir=/opt/open-xchange/etc/admindaemon -Dconfigdir=/opt/open-xchange/etc/admindaemon -Djava.util.logging.config.file=/opt/open-xchange/etc/admindaemon/file-logging.properties -Duser.timezone=GMT -Dlibdir=/opt/open-xchange/bundles/com.openexchange.common/lib -jar /opt/open-xchange/bundles/org.eclipse.osgi_3.3.0.v20070530.jar -configuration file:/opt/open-xchange/etc/admindaemon/osgi/


    admin and groupware servers are running

    bundles installed

    [root@manhattancenterstone sbin]# ./listbundles
    bundlename: org.eclipse.osgi status: ACTIVE
    bundlename: com.openexchange.authentication.database status: ACTIVE
    bundlename: com.openexchange.axis2 status: ACTIVE
    bundlename: com.openexchange.caching status: ACTIVE
    bundlename: com.openexchange.charset status: ACTIVE
    bundlename: com.openexchange.common status: ACTIVE
    bundlename: com.openexchange.configjump.generic status: ACTIVE
    bundlename: com.openexchange.configread status: ACTIVE
    bundlename: com.openexchange.control status: ACTIVE
    bundlename: com.openexchange.data.conversion.ical.ical4j status: ACTIVE
    bundlename: com.openexchange.global status: ACTIVE
    bundlename: com.openexchange.group.managerequest status: ACTIVE
    bundlename: com.openexchange.groupware.settings.extensions status: ACTIVE
    bundlename: com.openexchange.i18n status: ACTIVE
    bundlename: com.openexchange.imap status: ACTIVE
    bundlename: com.openexchange.mail.filter status: ACTIVE
    bundlename: com.openexchange.management status: ACTIVE
    bundlename: com.openexchange.monitoring status: ACTIVE
    bundlename: com.openexchange.passwordchange.database status: ACTIVE
    bundlename: com.openexchange.passwordchange.servlet status: ACTIVE
    bundlename: com.openexchange.push.udp status: ACTIVE
    bundlename: com.openexchange.resource.managerequest status: ACTIVE
    bundlename: com.openexchange.server status: ACTIVE
    bundlename: com.openexchange.sessiond status: ACTIVE
    bundlename: com.openexchange.smtp status: ACTIVE
    bundlename: com.openexchange.spamhandler.default status: ACTIVE
    bundlename: javax.servlet status: ACTIVE
    bundlename: net.freeutils.jcharset status: ACTIVE
    bundlename: org.apache.commons.logging status: ACTIVE
    bundlename: org.eclipse.equinox.event status: ACTIVE
    bundlename: org.eclipse.osgi.services status: ACTIVE


    Installation and configuration details

    /opt/open-xchange/sbin/initconfigdb -a -i --configdb-pass=db_password

    /opt/open-xchange/sbin/oxinstaller --servername=oxserver --configdb-pass=db_password \
    --master-pass=admin_master_password

    /opt/open-xchange/sbin/registerserver -n oxserver -A oxadminmaster -P admin_master_password

    mkdir /var/opt/filestore
    chown open-xchangepen-xchange /var/opt/filestore

    vim /etc/httpd/conf.d/proxy_ajp.conf

    LoadModule proxy_ajp_module modules/mod_proxy_ajp.so

    <Proxy *>
    Order deny,allow
    allow from all
    </Proxy>

    ProxyPass /axis2 ajp://127.0.0.1:8009/axis2 smax=0 ttl=60 retry=5
    ProxyPass /ajax ajp://127.0.0.1:8009/ajax smax=0 ttl=60 retry=5
    ProxyPass /servlet ajp://127.0.0.1:8009/servlet smax=0 ttl=60 retry=5
    ProxyPass /infostore ajp://127.0.0.1:8009/infostore smax=0 ttl=60 retry=5

    vim /etc/httpd/conf.d/ox.conf

    NameVirtualHost *
    <VirtualHost *>
    ServerAdmin webmaster@localhost

    DocumentRoot /var/www/vhosts/websiteaddresshere/

    <Directory /var/www/vhosts/websiteaddresshere//>
    AllowOverride None
    Order allow,deny
    allow from all
    RedirectMatch ^/$ /ox6/
    </Directory>

    ExpiresActive On
    ExpiresByType image/gif "access plus 23 hours"
    ExpiresByType image/png "access plus 23 hours"
    ExpiresByType image/jpg "access plus 23 hours"
    ExpiresByType image/jpeg "access plus 23 hours"
    ExpiresByType text/javascript "access plus 23 hours"
    ExpiresByType text/css "access plus 23 hours"
    ExpiresByType text/html "access plus 23 hours"
    ExpiresByType application/x-javascript "access plus 23 hours"
    <Files ~ "\.(js|css|gif|jpe?g|png)$">
    Header append Cache-Control "public"
    </Files>

    DeflateFilterNote ratio
    AddOutputFilterByType DEFLATE text/html text/plain text/xml text/css application/x-javascript
    BrowserMatch ^Mozilla/4 gzip-only-text/html
    BrowserMatch ^Mozilla/4\.0[678] no-gzip
    BrowserMatch \bMSI[E]*!no-gzip*!gzip-only-text/html
    Header append Vary User-Agent env=!dont-vary
    </VirtualHost>


    What other information should I post so you guys know what the problem is ?
    Last edited by jerbourq; 10-03-2008 at 07:32 PM.

  2. #2
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    would you please take a look at the Open-Xchange logfile and check if a error message is thrown if you try to upload?

    Greetings

  3. #3
    jerbourq Guest

    Default log files

    thanks for responding Martin,

    I cleared all the log files so I was left with no logged data inside them.
    I have these.
    0 -rw------- 1 root root 0 Oct 3 07:17 open-xchange-admin-console.log
    0 -rw------- 1 root root 0 Oct 3 09:04 open-xchange-admin.log.0
    0 -rw------- 1 open-xchange open-xchange 0 Oct 3 07:06 open-xchange-console.log
    0 -rw------- 1 open-xchange open-xchange 0 Oct 3 09:04 open-xchange.log.0


    I logged in with the testuser and tried to upload something to his infostore with the same problem. I checked the log files and there's nothing inside. That's the directory listnig after the fact so as you see, 0 bytes. Is there a way maybe to change the logging level ? Would an error be listed as severe if it occured for an upload to the infostore ?

  4. #4
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    If you delete or "clear" those log files, you'll have to restart the corresponding service.

    Greetings

  5. #5
    jerbourq Guest

    Default

    Hmm, this is interesting. This is what I get at the tail end of the open-xchange-admin.log.0

    SEVERE: Error creating RMI registry!
    java.rmi.ServerException: RemoteException occurred in server thread; nested exception is:
    java.rmi.UnmarshalException: error unmarshalling arguments; nested exception is:
    java.lang.ClassNotFoundException: com.openexchange.admin.rmi.OXUserInterface
    at sun.rmi.server.UnicastServerRef.oldDispatch(Unicas tServerRef.java:385)
    at sun.rmi.server.UnicastServerRef.dispatch(UnicastSe rverRef.java:240)
    at sun.rmi.transport.Transport$1.run(Transport.java:1 53)
    at java.security.AccessController.doPrivileged(Native Method)
    at sun.rmi.transport.Transport.serviceCall(Transport. java:149)
    at sun.rmi.transport.tcp.TCPTransport.handleMessages( TCPTransport.java:466)
    at sun.rmi.transport.tcp.TCPTransport$ConnectionHandl er.run(TCPTransport.java:707)
    at java.lang.Thread.run(Thread.java:595)
    at sun.rmi.transport.StreamRemoteCall.exceptionReceiv edFromServer(StreamRemoteCall.java:247)
    at sun.rmi.transport.StreamRemoteCall.executeCall(Str eamRemoteCall.java:223)
    at sun.rmi.server.UnicastRef.invoke(UnicastRef.java:3 43)
    at sun.rmi.registry.RegistryImpl_Stub.bind(Unknown Source)
    at com.openexchange.admin.daemons.AdminDaemon.initRMI (AdminDaemon.java:224)
    at com.openexchange.admin.daemons.Activator.start(Act ivator.java:94)
    at org.eclipse.osgi.framework.internal.core.BundleCon textImpl$2.run(BundleContextImpl.java:999)
    at java.security.AccessController.doPrivileged(Native Method)
    at org.eclipse.osgi.framework.internal.core.BundleCon textImpl.startActivator(BundleContextImpl.java:993 )
    at org.eclipse.osgi.framework.internal.core.BundleCon textImpl.start(BundleContextImpl.java:974)
    at org.eclipse.osgi.framework.internal.core.BundleHos t.startWorker(BundleHost.java:346)
    at org.eclipse.osgi.framework.internal.core.AbstractB undle.resume(AbstractBundle.java:350)
    at org.eclipse.osgi.framework.internal.core.Framework .resumeBundle(Framework.java:1118)
    at org.eclipse.osgi.framework.internal.core.StartLeve lManager.resumeBundles(StartLevelManager.java:634)
    at org.eclipse.osgi.framework.internal.core.StartLeve lManager.incFWSL(StartLevelManager.java:508)
    at org.eclipse.osgi.framework.internal.core.StartLeve lManager.doSetStartLevel(StartLevelManager.java:28 2)
    at org.eclipse.osgi.framework.internal.core.StartLeve lManager.dispatchEvent(StartLevelManager.java:468)
    at org.eclipse.osgi.framework.eventmgr.EventManager.d ispatchEvent(EventManager.java:195)


    This is what I get at the tail end of the open-xchange.log.0



    Oct 3, 2008 9:07:35 PM com.openexchange.monitoring.internal.MonitoringIni t start
    SEVERE: JMX-0001 Category=10 Message=MBean registration denied: ManagementAgent is not running. exceptionID=363108201-5
    JMX-0001 Category=10 Message=MBean registration denied: ManagementAgent is not running. exceptionID=363108201-5
    at com.openexchange.management.internal.ManagementAge ntImpl.registerMBean(ManagementAgentImpl.java:192)
    at com.openexchange.monitoring.internal.MonitoringIni t.start(MonitoringInit.java:118)
    at com.openexchange.monitoring.osgi.MonitoringActivat or.startBundle(MonitoringActivator.java:138)
    at com.openexchange.server.osgiservice.DeferredActiva tor.signalAvailability(DeferredActivator.java:271)
    at com.openexchange.server.osgiservice.DeferredActiva tor.access$100(DeferredActivator.java:79)
    at com.openexchange.server.osgiservice.DeferredActiva tor$DeferredServiceTrackerCustomizer.addingService (DeferredActivator.java:100)
    at org.osgi.util.tracker.ServiceTracker$Tracked.track Adding(ServiceTracker.java:1064)
    at org.osgi.util.tracker.ServiceTracker$Tracked.track (ServiceTracker.java:1042)
    at org.osgi.util.tracker.ServiceTracker$Tracked.servi ceChanged(ServiceTracker.java:967)
    at org.eclipse.osgi.framework.internal.core.FilteredS erviceListener.serviceChanged(FilteredServiceListe ner.java:94)
    at org.eclipse.osgi.framework.internal.core.BundleCon textImpl.dispatchEvent(BundleContextImpl.java:1224 )
    at org.eclipse.osgi.framework.eventmgr.EventManager.d ispatchEvent(EventManager.java:195)
    at org.eclipse.osgi.framework.eventmgr.ListenerQueue. dispatchEventSynchronous(ListenerQueue.java:141)
    371,2-9

  6. #6
    jerbourq Guest

    Default

    Any ideas anyone?

  7. #7
    Join Date
    Feb 2007
    Location
    Olpe
    Posts
    49

    Default Log entries still missing

    You have to look into the open-xchange.log.0 file. There the groupware application logs its messages. Please check this file if you restart the groupware. There should be a lot of messages when starting the server. The message you are showing above is from shutting down the server.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •