Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 8 of 8
  1. #1
    technikadonis Guest

    Question Für den Zugriff auf den Open-Xchange Server müssen Sie JavaScript aktivieren.

    Hallo ich habe folgendes Problem und bin mit der Suche zu keinem ergebnis gekommen.

    Wenn ich mich mit meinem OX-Server verbinden will bekomme ich "Für den Zugriff auf den Open-Xchange Server müssen Sie JavaScript aktivieren. " JavaScript läuft aber einwandfrei mit anderen Seiten.

    Ich habe ein openSUSE11-x64 und habe alles nach der Anleitung für openSUSE11 gemacht, von anderen Passwörtern mal abgesehen.
    An irgendwelche Fehlermeldungen kann ich mich nicht mehr erinnern.

    Ich habe auch bereits verschiedene Browser ausprobiert:

    Firefox 3.0.5, sowohl auf einer WinXP-Maschine als auch auf dem Server
    IE 7.0.5730.13, auf der XP-Mühle
    Konqueror 3.5.9 (KDE 3.5.9 "release 49.1" openSuse11.0), auf dem Server

    Die Fehlerkonsole von Firefox meldet:
    Fehler: check is not defined
    Quelldatei: http://xx.xx.xx.xx/ox6/
    Zeile: 85

    xx.xx.xx.xx ist die IP, ich habs auch mit "localhost" auf dem server probiert, daran sollte es aber nicht liegen.

    Die Zeile 85 sieht wie folgt aus: </div><script type="text/javascript">check()</script></body>

    mfg technikadonis

  2. #2
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hallo,

    ich gehe mal davon aus das auf den genannten Browsern Javascript aktiviert ist
    Kannst du bitte folgendes versuchen?
    * Cache des Browsers leeren
    * Schauen ob der Webserver die notwendigen Berechtigungen auf alle Dateien im wwwroot hat
    * Nachsehen ob alle benötigten Dateien im wwwroot liegen, nicht das vielleicht eine vorherige (De-)Installation etwas hinterlassen hat.

    Gruß

  3. #3
    technikadonis Guest

    Default

    Hallo Herr Braun,

    JavaScript ist natürlich aktiv gewesen, den Cache hatte ich auch schon geleert.

    Es waren noch die Zugriffsrechte auf root:root gesetzt jetzt hab ich sie auf wwwrun:www gesetzt und es geht.

    Danke für den Tipp, das sollte man aber vielleicht noch mit in die Anleitung aufnehmen, da ich mich ja an diese gehalten hatte.

    mfg technikadonis

  4. #4
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hallo!

    normalerweise dürfen diese Dateien nach der Installation nicht auf root:root gesetzt sein, das müssten die Installationspakete selbst erledigen. Ich schaue mir das mal an.

    Danke
    Martin

  5. #5
    Carsten Hoeger is offline Open-Xchange Professional Services
    Join Date
    Mar 2007
    Posts
    703

    Default

    Sie sind auf root und das funktioniert auch so, zumindest hier und bei vielen anderen scheinbar auch.

    Solange der apache Prozess die lesen kann, ist root als owner nicht wirklich ein Problem.

    Lesen sollte der die koennen bei 755, bzw. 644.

    Evtl. waren dann da die Permissions aus irgendeinem Grund falsch (640, oder 600).
    Kann ich mir aber auch nicht vorstellen.
    OXpedia.org - the answer to almost all questions.

  6. #6
    its Guest

    Default

    Hallo,

    ich bin gerade ziemlich ratlos.
    Habe gerade soweit alles installiert und erhalte beim Aufruf der Seite den gleichen Fehler:
    Code:
    You need to enable JavaScript to access the Open-Xchange Server.
    Für den Zugriff auf den Open-Xchange Server müssen Sie JavaScript aktivieren.
    Javascript ist aktiviert
    Cache gelöscht
    Zugriffsrechte stimmen
    Installation der letzten Stable Version unter openSuse in VMware

    Mache ich mir ein eigenes Beispiel, ist auch alles OK
    Code:
    <html><head><script type="text/javascript" src="js/hallo.js"></script></head><body><h1 onClick="javascript:HalloWelt();">It works!</h1><script type="text/javascript">HalloWelt();</script></body></html>
    Nehme ich hier nun check.js mit Aufruf check(); mit rein geht es wieder schief. Firebug meldet
    Code:
    check is not defined
     </div><script type="text/javascript">check()</script></body>\n
    Der Apache liefert die check.js aber mit Status 200 ordentlich aus.

    Hat hier noch jemand eine Idee wo ich suchen könnte?
    Der Aufruf von anderen OX Portalen funktioniert, am Browser kann es auch nicht liegen.
    Ich habe zum Ende des Seitenaufbaus auch noch keine Cookies gesetzt bekommen, ist das korrekt?

    Vielen Dank und viele Grüße
    Marc

  7. #7
    its Guest

    Default

    Here we are ...

    Nachdem ich festgestellt habe, dass die Javascript Datei zwar mit status 200 ausgeliefert wird, jedoch leer ist, bringt die Erweiterung der Zeile AddOutputFilterByType der VirtualHost Konfiguration um text/x-js den gewünschten Erfolg.

    Da mir anschließend noch einige Bilder fehlten, habe ich die Zeile nun wie folgt ergänzt und der Aufruf der Login Seite funktioniert:
    Code:
     AddOutputFilterByType DEFLATE text/html text/plain text/xml text/css application/x-javascript application/javascript text/x-js image/png image/gif image/jpg image/jpeg
    Könnte man das ganze eigentlich auch vie folgt abkürzen?
    Code:
    AddOutputFilterByType DEFLATE text/* image/* application/*
    Viele Grüße
    Marc

  8. #8
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi Marc,

    vermutlich könnte man es syntaktisch so abkürzen, aber dann würden auch alle Downloads wie Archive, Binaries usw. vom Webserver komprimiert und vom Browser dekomprimiert was für einige Last am Webserver sorgen wird.

    Gruß

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •