Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Page 1 of 2 12 LastLast
Results 1 to 10 of 14
  1. #1
    wolf Guest

    Default Install error in Debian

    Hi just created a new debian 5 to install Open-Xchange, I'd followed the install guide but i get errors at:


    /opt/open-xchange/sbin/registerfilestore -A oxadminmaster -P admin_master_password -t file:/var/opt/filestore

    /opt/open-xchange/sbin/registerdatabase -A oxadminmaster -P admin_master_password \-n oxdatabase -p db_password -m true


    Getting:

    filestore could not be registered:
    Error: Connection refused to host: localhost; nested exception is:
    java.net.ConnectException: Connection refused


    Just checked /host and set java version to 1.5 without success.

    Btw the login window at http://127.0.0.1/ox6/ox.html shows a 503 error (well no it seems java error)

    Any help?

    BTW the repository shows a http://127.0.0.1/ox6/ox.html NO_PUBKEY DD1A5E9CEED949F0
    http://software.open-xchange.com/OX6...nEtch/Packages 401 Authorization Required
    Last edited by wolf; 05-07-2010 at 12:19 PM.

  2. #2
    wolf Guest

    Default

    After creating a new server I'd been testing the pdf install guide.

    in :

    /opt/open-xchange/sbin/registerserver -n oxapp -A oxadminmaster \ -P mypw

    I get:

    server could not be registered:
    Error: connection failed to host: 127.0.0.1; nested exception is:
    java.net.ConnectException: Conexión rehusada

    and in mkdir data/filestores/fs1 a cannot create file error.

    I'm trying in Debian 5 without success



    Any help?

  3. #3
    Join Date
    Aug 2008
    Posts
    107

    Default

    Quote Originally Posted by wolf View Post
    After creating a new server I'd been testing the pdf install guide.

    in :

    /opt/open-xchange/sbin/registerserver -n oxapp -A oxadminmaster \ -P mypw

    I get:

    server could not be registered:
    Error: connection failed to host: blockedcontent; nested exception is:
    java.net.ConnectException: Conexión rehusada

    and in mkdir data/filestores/fs1 a cannot create file error.

    I'm trying in Debian 5 without success



    Any help?
    ... hope you didn't type the "\", because it only discribes a line break in the guide. Just skip it and try again.
    Viele Grüße
    Rene

    OS: Ubuntu Server amd64 12.4 LTS
    JRE: openjdk-7-jre, MySQL: 5.5, Apache 2.2, Dovecot 2.0.19
    OX-Server backend: OXSE latest
    OX-frontend: OXSE latest appsuite + ox6

  4. #4
    wolf Guest

    Default

    Nope, I didn't type the '\'. I'm following the pdf, now in page 20, mysql -h db1 -u openexchange -P 3306 -p changing db1 with my server name never get a connection and /opt/open-xchange/sbin/oxinstaller --add-license=YOUR-OX-LICENSE-CODE \ --servername=oxserver --configdb-pass=db_password \ --master-pass=admin_master_password --ajp-bind-port=localhost

    changing oxserver with my server name didn't fulfill the oxinstaller table, --servername & configdbpass are empty.

  5. #5
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Have you started the open-xchange-admindaemon before executing those commands? Please check out the quick installation guide, maybe it's clearer than the pdf. http://oxpedia.org/wiki/index.php?ti...for_Debian_5.0
    Last edited by Martin Heiland; 05-10-2010 at 05:53 PM.

  6. #6
    wolf Guest

    Default

    Yes, I'd tried almost everything, always the java error and oxinstaller shows empty server name and db password. Damn I need to get it online to test it before creating a real server, is Open-Xchange or Zimbra for us.

  7. #7
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    could you try using the installation script? It does all the required stuff in an automated way. I don't exactly know the cause for your issue but you might give it a try on a clean debian system.

    http://oxpedia.org/wiki/index.php?ti...install_script

    Greetings

  8. #8
    wolf Guest

    Default

    In a clean Debian 5 installation, at the very end of the script I get:

    Sleeping 10 seconds...
    Registering groupware system at the database...
    server could not be registered:
    Server response:
    Exception creating connection to: 192.168.0.166; nested exception is:
    java.net.NoRouteToHostException: No route to host
    Server cannot be registered, aborting.

    so....

    Ok, reinstalled Debian again and reinstall OX, everything went OK, time to test.

    Thank you very much.
    Last edited by wolf; 05-12-2010 at 01:06 PM. Reason: update

  9. #9
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    i assume this was an error with /etc/hosts pointing to a wrong "localhost" IP address.

    Greetings

  10. #10
    wolf Guest

    Default

    I think so, btw which user should I user to config OX and users, oxadminmaster or oxadmin?

    How can I set oxadminmaster pass?

    thanx

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •