Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 7 of 7
  1. #1
    Join Date
    Apr 2011
    Posts
    121

    Post Fehler USM access disabled for user

    Ich habe schon alles versucht was ich hier gefunden habe, aber der Fehler bleibt.
    Weiß jemand noch einen Rat?

    System: SUSE Linux Enterprise Server 11 (x86_64), VERSION = 11, PATCHLEVEL = 1

    Fehlermeldung "USM access disabled for user"

    der Befehl
    changeuser -c 1 -A oxadmin -P *** -u unser_user --access-active-sync true --access-usm true

    liefert ---> user unser_user in context 1 changed

    Aber der User bekommt weiterhin keinen Zugang!

    Ein Test-User der nun angelegt wurde funktioniert problemlos

    open-xchange-usm ist die Version 6.20.0.0-3_3.1
    Und alle anderen Kompomenten von open-Xchange haben die Version 6.20.0.0-3_3.1


    /opt/open-xchange/sbin/report -d
    gibt aus:

    module version
    admin 6.20.0 Rev3
    groupware 6.20.0 Rev3

    contexts users
    4 254

    id age created admin permission module access combination
    1 573 Tue Sep 15 15:42:34 CEST 2009 33554431 132382719
    1 573 Tue Sep 15 15:42:34 CEST 2009 33554431 134217727
    1 573 Tue Sep 15 15:42:34 CEST 2009 33554431 33554431
    1 573 Tue Sep 15 15:42:34 CEST 2009 33554431 3145733
    3 575 Mon Sep 14 14:21:36 CEST 2009 31719423 2359295
    3 575 Mon Sep 14 14:21:36 CEST 2009 31719423 33554431
    3 575 Mon Sep 14 14:21:36 CEST 2009 31719423 31719423
    5 460 Wed Jan 06 21:15:30 CET 2010 31719423 33554431
    5 460 Wed Jan 06 21:15:30 CET 2010 31719423 31719423
    6 430 Fri Feb 05 16:22:30 CET 2010 31719423 31719423
    6 430 Fri Feb 05 16:22:30 CET 2010 31719423 33554431


    Was will der Server denn noch?
    Last edited by Victor; 04-12-2011 at 04:47 PM.

  2. #2
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hallo,

    kannst du bitte die komplette Fehlermeldung posten? Funktioniert es vielleicht nach einem OX Neustart für den entsprechenden Benutzer?

    Gruß

  3. #3
    Join Date
    Apr 2011
    Posts
    121

    Default

    Die Fehlermeldung in open-xchange.log.0 lautet
    INFO: user366@unsredomain.com: USM access disabled for user

    Bis jetzt wurde immer die open-xchange-groupware restartet, ohne Erfolg.
    Gruß,
    Victor

  4. #4
    Join Date
    Apr 2011
    Posts
    121

    Default

    also ich habe es auch mit
    changeaccessglobal -A oxadminmaster -P *** --access-active-sync true --access-usm true
    versucht, der Server nimmt den Befehl ohne irgendwelche Rückmeldung.
    "USM access disabled for user" bleibt aber weiterhin.


    ich habe mir nun für den Context 1 alle Modulzugriffe auflisten lassen, mit
    getmoduleaccessforcontext -A oxadminmaster -P ***
    -------------------------------------------------------------------------
    access-calendar,access-contacts,access-delegate-tasks,access-edit-public-folder,access-forum,access-ical,access-infostore,access-pinboard-write,access-projects,access-read-create-shared-Folders,access-rss-bookmarks,access-rss-portal,access-syncml,access-tasks,access-vcard,access-webdav,access-webdav-xml,access-webmail,access-edit-group,access-edit-resource,access-edit-password,access-collect-email-addresses,access-multiple-mail-accounts,access-publication,access-subscription,access-active-sync,access-usm,access-olox20,access-global-address-book-disabled,access-public-folder-editable
    "true","true","true","true","true","true","true"," true","true","true","true","true","true","true","t rue","true","true","true","true","true","true","tr ue","true","true","true","false","false","false"," false","true"
    ------------------------------------------------------

    Die Ausgabe ist ziemlich unübersichtlich, aber offenslichtlich ist access-usm auf "felse"

    Weiß einer wie ich den zugriff auf das usm-modul freigebe wenn die oberen Befehle nicht greifen?
    Last edited by Victor; 07-14-2011 at 05:25 PM.

  5. #5
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    kommt denn irgend eine Art Fehler im Log des Admindaemon (open-xchange-admin.log) wenn du die Rechte setzen willst? Ist das open-xchange-usm *und* das open-xchange-eas Paket installiert?

    Gruß

  6. #6
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Achso, eins noch: Die Parameter erwarten keine boolean sondern "on" oder "off"
    Code:
    --access-usm on --access-active-sync on
    vielleicht war es das schon?

  7. #7
    Join Date
    Apr 2011
    Posts
    121

    Default

    Quote Originally Posted by Martin Braun View Post
    Achso, eins noch: Die Parameter erwarten keine boolean sondern "on" oder "off"
    Code:
    --access-usm on --access-active-sync on
    vielleicht war es das schon?
    ja, daran lag es.

    mit
    --access-usm on
    und
    --access-active-sync on
    läuft es.
    In den Foren standen die Befehle mit "true" statt "on"
    und der Server hat die Befehle auch so angenommen und gemeldet "user ... in context... changed" obwohl es falsch war.

    Also das Problem ist endlich gelöst,
    vielen lieben Dank.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •