Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 7 of 7
  1. #1
    juliusspencer Guest

    Red face package org.springframework.beans.factory.xml does not exist

    Hi,

    I've started building now I have the source and I have the following error. It looks like it can't find spring-beans.jar.

    Code:
    ant -Dlib.dir=/opt/open-xchange/lib install
    Code:
    /tmp/open-xchange/src/com/openexchange/ajax/ImportExport.java:58: package org.springframework.beans.factory.xml does not exist
    Yet I have:

    Code:
    ll /opt/open-xchange/lib/ | grep spring
    -rw-r--r-- 1 root root  230640 2007-11-18 19:37 spring-beans.jar
    -rw-r--r-- 1 root root  121409 2007-11-18 19:37 spring-core.jar
    Any ideas what I might be doing wrong?

  2. #2
    Join Date
    Oct 2007
    Location
    XiaMen, FuJian ,China
    Posts
    47

    Default

    hi
    You can try usage vmware.
    download address: http://www.open-xchange.com/forum/showthread.php?t=40

  3. #3
    juliusspencer Guest

    Default

    Hi,

    Thanks for the reply... not sure I understand. Do you think I should try setting up vmware?

    I'm trying to keep it simple by just compiling open-xchange.

  4. #4
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    did you download the spring framework jar files?

    Greetings

  5. #5
    juliusspencer Guest

    Default

    Hi,

    I believe so I have downloaded the following:

    Code:
    drwxr-xr-x 9 root    root        4096 2006-02-27 21:44 spring-framework-1.2.7
    And I took out the jars to put into /opt/open-xchange/lib/

    When in the directory I did this:
    Code:
      567  cp /var/adm/Downloads/spring-framework-1.2.7/dist/spring-core.jar .
      568  cp /var/adm/Downloads/spring-framework-1.2.7/dist/spring-beans.jar .
    Maybe I made a mistake here...

    Schönen Dank : )

  6. #6
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    jep, those files must be renamed:
    spring-core_1.2.7.jar
    spring-beans_1.2.7.jar

    Greetings

  7. #7
    juliusspencer Guest

    Smile [SOLVED]

    Hi,

    Danke sehr! The trick was to make sure all the jars were named as expected (by build.xml I guess).

    (as is in the manual; sorry about that!)

    Code:
    BUILD SUCCESSFUL
    Total time: 23 seconds

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •