Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 7 of 7
  1. #1
    Join Date
    Dec 2012
    Location
    Germany
    Posts
    46

    Exclamation Guard 2.4 not available in AppSuite 7.8.1

    Hi,

    I recently updated my OX installation.

    The versions are now 7.8.1 for AppSuite and 2.4 for the Guard.

    I used the migration guide to upgrade OX guard.

    After restarting open-xchange and migrating the guard database, the guard test ist successfull:
    Code:
    root@HOST:# /opt/open-xchange/sbin/guard --test E-MAIL
    Response received.  Testing JSON
    {"E-MAIL":{"uid":6,"cid":1,"user":{"language":"de_DE","displayName":"MY NAME"}}}
    User id 6
    Context 1
    Language de_DE
    Name MY NAME
    Success
    I can't find any problems in the log file. But Guard isn't available in the AppSuite Webfrontend.

    Any ideas how I can fix Guard or find any usefull logs?

    Thank you!

  2. #2
    Join Date
    Sep 2007
    Location
    Germany
    Posts
    494

    Default

    It could be anything but to my own experience it might be a configuration issue in Apache.

    You may find an error when you watch the console with Firebug or similar during login. If you get a 404 for the Guard login request it's most likely Apache configuration.
    If you have Apache 2.2 then this is likely the issue:

    # NOTE for Apache versions < 2.4:
    # When using a single node system or using BalancerMembers that are assigned to other balancers please add a second hostname for that
    #
    # Example from /etc/hosts: 127.0.0.1 localhost localhost_sync

    or you can try to change the ProxyPass directives as a workaround which seems to work fine (in principle):

    ProxyPass /appsuite/api/oxguard balancer://oxguard/oxguard
    ProxyPass /pks balancer://oxguardpgp/pgp

  3. #3
    Join Date
    Dec 2012
    Location
    Germany
    Posts
    46

    Default

    I can not find any hint to OX Guard in the AppSuite. There are no server requests to ox guard.

    The OX backend and OX Guard run on the same machine.

    I use different "localhosts" in apache and OX configuration.

    Is there an option to check the running OX-components at the OSGi?

  4. #4
    Join Date
    Sep 2007
    Location
    Germany
    Posts
    494

    Default

    listbundles | grep guard

    should look like this:
    bundlename: com.openexchange.guard.api status: ACTIVE
    bundlename: com.openexchange.guard.backend status: ACTIVE
    bundlename: com.openexchange.guard.bad status: ACTIVE
    bundlename: com.openexchange.guard.cipher status: ACTIVE
    bundlename: com.openexchange.guard.common status: ACTIVE
    bundlename: com.openexchange.guard.configuration status: ACTIVE
    bundlename: com.openexchange.guard.database status: ACTIVE
    bundlename: com.openexchange.guard.dns status: ACTIVE
    bundlename: com.openexchange.guard.email.storage status: ACTIVE
    bundlename: com.openexchange.guard.encryption status: ACTIVE
    bundlename: com.openexchange.guard.guestupgrade status: ACTIVE
    bundlename: com.openexchange.guard.hkp status: ACTIVE
    bundlename: com.openexchange.guard status: ACTIVE
    bundlename: com.openexchange.guard.keys status: ACTIVE
    bundlename: com.openexchange.guard.logging status: ACTIVE
    bundlename: com.openexchange.guard.mailcreator status: ACTIVE
    bundlename: com.openexchange.guard.management status: ACTIVE
    bundlename: com.openexchange.guard.notification status: ACTIVE
    bundlename: com.openexchange.guard.oxapi status: ACTIVE
    bundlename: com.openexchange.guard.ratifier status: ACTIVE
    bundlename: com.openexchange.guard.session status: ACTIVE
    bundlename: com.openexchange.guard.settings status: ACTIVE
    bundlename: com.openexchange.guard.storage.file status: ACTIVE
    bundlename: com.openexchange.guard.storage status: ACTIVE
    bundlename: com.openexchange.guard.translation status: ACTIVE
    bundlename: com.openexchange.guard.update status: ACTIVE
    bundlename: com.openexchange.guard.user status: ACTIVE

    Also check if everything is installed:
    open-xchange-guard-reader-2.4.0-5_5.1.noarch
    open-xchange-guard-ui-static-2.4.0-7_7.1.noarch
    open-xchange-guard-ui-2.4.0-7_7.1.noarch
    open-xchange-guard-backend-plugin-2.4.0-7_7.1.noarch
    open-xchange-guard-file-storage-2.4.0-7_7.1.noarch
    open-xchange-guard-2.4.0-7_7.1.noarch

    and if the user has the the right permissions:
    getuserconfigurationsource

  5. #5
    Join Date
    Dec 2012
    Location
    Germany
    Posts
    46

    Default

    Thank you for the fast answer!

    After upgrading to 2.4, com.openexchange.capability.guard=true was not recognized. I copied the guard-api.properties-file new and now Guard is enabled. I get now some 404 errors

    listbundles shows: bundlename: com.openexchange.guard.backend status: RESOLVED, but I can't find some misconfiguration.

    My guard-core.properties shows like this:
    Code:
    com.openexchange.guard.oxGuardDatabaseHostname=localhost
    
    com.openexchange.guard.oxGuardShardDatabase=localhost
    
    com.openexchange.guard.databaseUsername=openexchange
    com.openexchange.guard.databasePassword=PW
    
    
    com.openexchange.guard.supportApiUsername=USER
    com.openexchange.guard.supportApiPassword=PW
    
    com.openexchange.guard.productName=Guard
    
    com.openexchange.guard.upgrader.version=7
    
    com.openexchange.guard.exposedKeyDurationInHours=168
    
    com.openexchange.guard.restApiHostname=localhost_guard
    
    
    com.openexchange.guard.restApiUsername=USER
    com.openexchange.guard.restApiPassword=PW
    
    com.openexchange.guard.externalReaderPath=URL/guard/reader/reader.html
    
    com.openexchange.guard.externalEmailURL=URL
    
    com.openexchange.guard.templatesDirectory=/opt/open-xchange/templates/guard
    
    com.openexchange.guard.aesKeyLength=256
    com.openexchange.guard.rsaKeyLength=2048
    
    com.openexchange.guard.keyValidDays=3650
    
    com.openexchange.guard.publicPGPDirectory=hkp://keys.gnupg.net:11371, hkp://pgp.mit.edu:11371
    
    com.openexchange.guard.pgpCacheDays=7
    
    com.openexchange.guard.cacheDays=30
    
    com.openexchange.guard.cronHour=2
    
    com.openexchange.guard.guestSMTPServer=SERVER
    com.openexchange.guard.guestSMTPPort=25
    com.openexchange.guard.guestSMTPUsername=USER
    com.openexchange.guard.guestSMTPPassword=PW
    
    com.openexchange.guard.passwordFromAddress=MAIL
    com.openexchange.guard.passwordFromName=NAME
    Any ideas to fix this?

    Thanks!

  6. #6
    Join Date
    Sep 2007
    Location
    Germany
    Posts
    494

    Default

    Are there other bundles in "RESOLVED" state?
    What is the output of "getmissingservices"?

    Is there anything in the logs about the startup of guard.backend?

  7. #7
    Join Date
    Dec 2012
    Location
    Germany
    Posts
    46

    Default

    Ok, thanks for you help. I did an very stupid mistake. I used "localhost_guard" as second name for localhost. Ping to localhost_guard works, but set as configuration option, it was rejected and 'null' was set as hostname for guard api.

    I fixed it and now everything is working perfecty. Thank you!

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •