Announcement

Collapse
No announcement yet.

Error after Updating to OX 7.10.3

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error after Updating to OX 7.10.3

    Hello,

    today I updated my OX Appsuite installation to the new v7.10.3-3.

    The update process was okay, no errors occurred. The OX server starts and I can login via webinterface. But in the log file (open-xchange.log.0), there is frequently the following error:

    Code:
    2019-12-05T14:02:58,890+0100 ERROR [ActiveMQ Task-1] org.apache.activemq.transport.failover.FailoverTransport.doReconnect(FailoverTransport.java:1080)
    Failed to connect to [] after: 3 attempt(s)
    2019-12-05T14:02:58,891+0100 ERROR [RT2AdminJmsConsumer-2] org.springframework.jms.listener.DefaultMessageListenerContainer.refreshConnectionUntilSuccessful(DefaultMessageListenerContainer.java:962)
    Could not refresh JMS Connection for destination 'topic://admin-Topic' - retrying using ExponentialBackOff{currentInterval=60000ms, multiplier=1.5}. Cause: No uris available to connect to.
    2019-12-05T14:02:59,904+0100 ERROR [ActiveMQ Connection Executor: unconnected] com.zaxxer.hikari.pool.HikariPool.throwPoolInitializationException(HikariPool.java:574)
    null - Exception during pool initialization.
    java.sql.SQLException: Access denied for user ''@'localhost' (using password: NO)
        at com.mysql.jdbc.SQLError.createSQLException(SQLError.java:965)
        at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:3933)
        at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:3869)
        at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:864)
        at com.mysql.jdbc.MysqlIO.proceedHandshakeWithPluggableAuthentication(MysqlIO.java:1707)
        at com.mysql.jdbc.MysqlIO.doHandshake(MysqlIO.java:1217)
        at com.mysql.jdbc.ConnectionImpl.coreConnect(ConnectionImpl.java:2189)
        at com.mysql.jdbc.ConnectionImpl.connectOneTryOnly(ConnectionImpl.java:2220)
        at com.mysql.jdbc.ConnectionImpl.createNewIO(ConnectionImpl.java:2015)
        at com.mysql.jdbc.ConnectionImpl.<init>(ConnectionImpl.java:768)
        at com.mysql.jdbc.JDBC4Connection.<init>(JDBC4Connection.java:47)
        at sun.reflect.GeneratedConstructorAccessor170.newInstance(Unknown Source)
        at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
        at java.lang.reflect.Constructor.newInstance(Constructor.java:423)
        at com.mysql.jdbc.Util.handleNewInstance(Util.java:425)
        at com.mysql.jdbc.ConnectionImpl.getInstance(ConnectionImpl.java:385)
        at com.mysql.jdbc.NonRegisteringDriver.connect(NonRegisteringDriver.java:323)
        at com.zaxxer.hikari.util.DriverDataSource.getConnection(DriverDataSource.java:136)
        at com.zaxxer.hikari.pool.PoolBase.newConnection(PoolBase.java:369)
        at com.zaxxer.hikari.pool.PoolBase.newPoolEntry(PoolBase.java:198)
        at com.zaxxer.hikari.pool.HikariPool.createPoolEntry(HikariPool.java:467)
        at com.zaxxer.hikari.pool.HikariPool.checkFailFast(HikariPool.java:541)
        at com.zaxxer.hikari.pool.HikariPool.<init>(HikariPool.java:115)
        at com.openexchange.office.tools.database.DocumentsDatabase.implCreateConnectionPool(DocumentsDatabase.java:249)
        at com.openexchange.office.tools.database.DocumentsDatabase.implCreateConnectionPools(DocumentsDatabase.java:206)
        at com.openexchange.office.tools.database.DocumentsDatabase.<init>(DocumentsDatabase.java:107)
        at com.openexchange.office.dcs.registry.database.DCSDatabase.<init>(DCSDatabase.java:95)
        at com.openexchange.office.dcs.registry.database.DCSDatabaseFactory.getDcsDatabase(DCSDatabaseFactory.java:45)
        at com.openexchange.office.rt2.jms.JmsComponentFactory.getFailoverBrokerUrl(JmsComponentFactory.java:169)
        at com.openexchange.office.rt2.jms.JmsComponentFactory.access$100(JmsComponentFactory.java:76)
        at com.openexchange.office.rt2.jms.JmsComponentFactory$1.onException(JmsComponentFactory.java:153)
        at org.apache.activemq.ActiveMQConnection$6.run(ActiveMQConnection.java:1994)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
        at java.lang.Thread.run(Thread.java:748)
    Can anybody help me with this issue? Thanks in advance.

    Rene
    Last edited by 881822; 12-05-2019, 03:16 PM.
    Viele Gre
    Rene

    OS: Ubuntu Server amd64 16.4 LTS
    JRE: openjdk-8-jre, MySQL 5.7, Apache 2.4, Dovecot 2.2.22
    OX-Server backend: OXSE latest
    OX-frontend: OXSE latest appsuite + ox6

  • #2
    Same here.

    Comment


    • #3
      Smells like Document Collaboration Service not available or something like this?

      Was everything installed and setup correctly according to https://oxpedia.org/wiki/index.php?t...allation_Guide

      Or, different question: Is OX Documents in use and granted to your users at all?

      Comment


      • #4
        Hallo Wolfgang.

        Thanks for your reply. I think, you are right. It is due to the missing DCS installation. I was reading the installation instruction on and on but I don't get which credentials I need to enter. Following the instruction I get the following error message:

        Code:
        Reading default values from properties file: '/etc/documents-collaboration/dcs.properties'
        
        initializing dcsdb from scratch...
        
        ERROR 1045 (28000): Access denied for user 'openexchange'@'localhost' (using password: YES)
        
        ERROR
        Even if I manage to see

        Code:
        Reading default values from properties file: '/etc/documents-collaboration/dcs.properties'
        
        initializing dcsdb from scratch...
        I still see the above mentioned error in the open-xchange.log.0 file.

        Could you please bring some light in the zoo of db users?

        Thanks.




        Comment


        • #5
          Indeed, you are right - everything fine now.

          Thanks
          Viele Gre
          Rene

          OS: Ubuntu Server amd64 16.4 LTS
          JRE: openjdk-8-jre, MySQL 5.7, Apache 2.4, Dovecot 2.2.22
          OX-Server backend: OXSE latest
          OX-frontend: OXSE latest appsuite + ox6

          Comment


          • #6
            Originally posted by 881822 View Post
            Indeed, you are right - everything fine now.

            Thanks
            Hi.

            May I ask you what you have done? I can't get it solved...

            Thanks in advance.

            Comment


            • #7
              Originally posted by oxox View Post

              Hi.

              May I ask you what you have done? I can't get it solved...

              Thanks in advance.
              Hi,

              I decided to add another root user to my Mysql, e. g. "admin" and gave him a password (which "root" doesn't has under Ubuntu 18.04). Now you can use the initdcsdb-order as follows:

              Code:
              initdcsdb.sh -a --dcsdb-pass=secret --mysql-root-user=<name-of-new-root-user> --mysql-root-passwd=secret
              That worked for me.
              Viele Gre
              Rene

              OS: Ubuntu Server amd64 16.4 LTS
              JRE: openjdk-8-jre, MySQL 5.7, Apache 2.4, Dovecot 2.2.22
              OX-Server backend: OXSE latest
              OX-frontend: OXSE latest appsuite + ox6

              Comment


              • #8
                Originally posted by 881822 View Post

                Hi,

                I decided to add another root user to my Mysql, e. g. "admin" and gave him a password (which "root" doesn't has under Ubuntu 18.04). Now you can use the initdcsdb-order as follows:

                Code:
                initdcsdb.sh -a --dcsdb-pass=secret --mysql-root-user=<name-of-new-root-user> --mysql-root-passwd=secret
                That worked for me.
                Thanks. I got it fixed now. I don't see any error now. However, I can't open any MS Office files (docx, xlsx etc.) It says
                Code:
                Sorry, your document is very large. It will take some time to be loaded.
                I am talking about a file size of couple of KB...

                Any ideas?

                Comment


                • #9
                  Just to add that legacy format (doc etc.) and pdf is working fine.

                  Comment


                  • #10
                    Hm... no ideas?

                    Comment


                    • #11
                      That error is extremely generic.
                      It could be broken websocket support or a mismatch in installation (not all packages updated correctly) or DCS communication.
                      You might get a hint when examining the webconsole for any suspicious hints or errors.

                      Comment

                      Working...
                      X