Announcement

Collapse
No announcement yet.

Email accounts

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Email accounts

    Hi,

    I do currently still not understand how OX work with Cyrus and Postfix, so it would be appreciated if someone can explain me more (or give me some links) about how they work together.

    Does OX also create the email account when we create an OX account or do we need to set up POP3 account separately?

    Thanks in advance.

  • #2
    Hi,

    OX as a groupware works like a E-Mail Client, just like Thunderbird or Outlook. We use Postfix to send E-Mail and use Cyrus to access mailboxes via IMAP, that's all. You could also configure a OX user account to point to your webmail providers backend and use their mail servers for example. In contrast to products like Zimbra or Scalix we don't want to replace existing infrastructure by our own but leverage and support it as good as possible. We use Cyrus and Postifx by default in some Products, but we support a protocol, not a specific server software so you'll be able to run OX against dovecot or courier or any other standards compliant IMAP implementation.

    Example, how to access a mailbox:
    via Thunderbird:
    Thunderbird -> IMAP Server-> Message store

    via OX:
    OX GUI -> OX Server - IMAP Server-> Mesage store

    Example, how to send mail:
    via Outlook:
    Outlook -> SMTP Server -> Recipients Server -> Recipients Mailbox

    via OX:
    OX GUI -> OX Server -> SMTP Server -> Recipients Server -> Recipients Mailbox

    As you can see we're adding client functionality to the OX Server, in a transparent way.

    To make life easier for our customers and the community, we added some features to the OX Admin service (open-xchange-admin) which does some configuration work for you. For example, when creating a OX user, a IMAP and SMTP account will also be added for this user. Those helpers are cyrus/postifx dependent but it are just addons, no required part of the Groupware.

    Hope that helps
    Last edited by Martin Heiland; 05-20-2008, 12:24 AM.

    Comment


    • #3
      That helped a lot, Martin! Thank you very much.

      But I have tried to fetch email from another server. Nothing happens! What should I do?

      Code:
      cyradm> info
      info: no connection to server

      Comment


      • #4
        I can not connect to existing mail server. Can someone please help me ? I used fetchmail in admin GUI but nothing happens.

        Comment


        • #5
          Since OX uses other services for mail handling you should have a look at your logfiles for mail (for my Ubuntu system thats /var/log/mail.log) - and maybe post it here. Also your fetchmail configuration file (/etc/fetchmailrc) would be intersting to solve your problem.

          Just a stupid question: Is fetchmail installed on your system? I used the manual installation guide in the wiki and fetchmail is not installed by default if you follow the wiki. I do not know if the install script includes fetchmail.

          If you want to use an existing mail server, Martin gave the instructions for that in another thread.
          Last edited by Dorowan; 05-23-2008, 10:38 AM.

          Comment


          • #6
            Hello,

            fetchmail is working, but maybe I have problem with accounts setting ...

            Code:
            fetchmail: 3 messages for xxx@xxx.com at mail.xxx.com (12810 octets)
            When I try to delete an user with commandline, there is a problem

            Code:
            localhost:/opt/open-xchange/sbin # ./deleteuser --username test --contextid 1 --adminuser oxadmin --adminpass 1234
            user test in context 1 could not be deleted: 
            Server response:
             The following exceptions occured in the plugins: com.openexchange.admin.plugins.PluginException: com.openexchange.admin.rmi.exceptions.OXUserIMAPException: Folder does not exist.
            I have also tried with command line to add an user with --dbonly, --imapserver and --smtpserver options. Afterthat I can not list the users by listuser command any more. If I delete this new created user, then everything is back to normal.
            Code:
            localhost:/opt/open-xchange/sbin # ./listuser --contextid 1 --adminuser oxadmin --adminpass 1234
            Server response:
             java.net.ConnectException: Connection timed out
            Here are the repeated errorlog in /var/log/mail
            Code:
            May 24 14:12:26 office postfix/smtpd[16137]: fatal: open /etc/postfix/ldap-aliases.cf: No such file or directory
            May 24 14:12:27 office postfix/master[22137]: warning: process /usr/lib/postfix/smtpd pid 16137 exit status 1
            May 24 14:12:27 office postfix/master[22137]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling
            Other logs in /var/log/fetchmail
            Code:
            fetchmail: Query status=10 (SMTP)
            fetchmail: sleeping at Sat May 24 13:56:26 2008 for 600 seconds
            fetchmail: awakened at Sat May 24 14:06:26 2008
            fetchmail: Server CommonName mismatch: localhost != mail.xxx.com
            fetchmail: Server certificate verification error: self signed certificate
            fetchmail: Server certificate verification error: certificate has expired
            Here is fetchmailrc
            Code:
            # Automaticly generated file by the open-xchange-admin-daemon. Do not edit this file!
            
            set no syslog
            set logfile /var/log/fetchmail.log
            set postmaster "oxadmin"
            set daemon 120
            
            poll 'mail.xxx.com' with proto pop3
                    user 'test@xxx.com' there with password '1234' is 'oxadmin' here keep
            xxx are modified text, sorry if it is annoyed.

            Please tell me if you need any other information.

            Thank you very much

            Comment


            • #7
              Hi,

              to avoid problems with existing mailserver infrastructure, you should try to use the --dbonly flag. This will only delete/create/list a user at the groupware but does not try to remove the user from the mailserver

              Greetings

              Comment


              • #8
                Originally posted by Martin Braun View Post
                Hi,

                to avoid problems with existing mailserver infrastructure, you should try to use the --dbonly flag. This will only delete/create/list a user at the groupware but does not try to remove the user from the mailserver

                Greetings
                Thank you very much. I have added --dbonly flag to listuser and deleteuser commands and got no more error messages. But there is some problem with the user created by this command
                Code:
                /opt/open-xchange/etc/groupware # /opt/open-xchange/sbin/createuser --contextid 1 --adminuser oxadmin --adminpass 1234 --dbonly --username abc --imaplogin abc@xxx.com --displayname T --givenname T --surname T --password '123456' --email abc@xxx.com --imapserver mail.xxx.com --smtpserver mail.xxx.com
                xxx.com is existing email server running on other machine. It takes very long to login (until something timed out) and mail function is disabled. Error message:
                Code:
                05-25-2008 01:48 AM-->Error code: Connection was refused or timed out while attempting to connect to remote server localhost for user abc (MSG-0001,1502525486-639)
                I think it should not be localhost but mail.xxx.com

                Comment


                • #9
                  Hi,

                  mail.xxx.com is just the server which is entered to the database, you set the --dbonly flag, so
                  there will be now operations taking place on a remote system. Would you please take a look
                  at /vat/log/open-xchange.log.0 if there are some more information. Another useful information
                  would be the database entry of the open-xchange-db.users table.

                  Greetings

                  Comment


                  • #10
                    I did some steps forward. That problem is maybe at mail server's side. I have disabled firewall on Mail server and now I can login with the account created above.

                    But mail does still not work. Here are some error messages:

                    On http://yyy.com/ox/admin/ => User setup
                    Code:
                    Error code: Error occured in: com.openexchange.admin.rmi.extensions.OXUserMailfilterExtension! Errortext: java.net.ConnectException: Connection refused (SVL-0001,1502525486-921)
                    My email server require login name in form 'test@xxx.com'. I have also used flag --imaplogin but same problem.

                    Code:
                    localhost:/home # /opt/open-xchange/sbin/createuser --contextid 1 --adminuser oxadmin --adminpass 1234 --dbonly --username test --imaplogin 'test@xxx.com' --displayname X --givenname X --surname X --password '1234' --email test@xxx.com --imapserver mail.xxx.com --smtpserver mail.xxx.com
                    [ 
                    com.openexchange.admin.rmi.dataobjects.User@f8968f
                     Mandatory members:
                      Create: name display_name password given_name sur_name primaryEmail 
                      Change: NONE
                      Delete: NONE
                      Register: NONE
                      contextadmin: false
                      id: 36
                      name: contact
                      passwordMech: CRYPT
                      primaryEmail: test@xxx.com
                      email1: test@xxx.com
                      aliases: [test@xxx.com]
                      sur_name: X
                      given_name: X
                      mailenabled: true
                      display_name: X
                      imapServer: mail.xxx.com
                      smtpServer: mail.xxx.com
                      imapLogin: test@xxx.com
                      language: en_US
                      password_expired: false
                      defaultSenderAddress: test@xxx.com
                    ]
                    I have also created an user name called 'test@xxx.com' but can not login with this account. (Error: no user/password found)

                    Comment


                    • #11
                      Hi,

                      this issue may be related to http://www.open-xchange.com/forum/showthread.php?t=1397 ?

                      Greetings

                      Comment

                      Working...
                      X