Announcement

Collapse
No announcement yet.

ox-gui build failed

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    And you go by wiki installation howto or do you change a few parts?
    Because there are some parts which could easily missunderstand:

    1.) IV.2. Open-Xchange Admindaemon Installation

    My edit here was:
    You have to go in every folder (cd /tmp/open-xchange-admin/) Then do:
    & ant -Dlib.dir=/opt/open-xchange/lib install

    is it right so?

    2.)Do you use cyrus 2.1 or 2.2?

    3.)Can you post a complete Mailconfiguration howto? with fetching mails or as relay host? that would be very fine


    4.)is there a way where i can add easily more than 100 users to the system? or do i have to use the createuser script?
    Last edited by altariq; 03-21-2007, 01:04 PM.

    Comment


    • #32
      1)
      you don't need to go in every subfolder. when you compile open-xchange-admin the plugins will be compiled automatically.

      2)
      I use cyrus 2.1

      3)
      you can find a complete howto for edgy:
      https://help.ubuntu.com/community/Postfix (for postfix)
      https://help.ubuntu.com/community/Cyrus (for cyrus)

      4)
      I don't know, I have only 2 users

      Comment


      • #33
        well, i got the same trouble here...
        just as a note: i followed the wiki step by step.

        no i`ll start looking for that issue. can`t wait for it

        greets, Nik


        Originally posted by altariq View Post
        I tried to setup ox on a new server. Before i had different errormessages and now i still have errors. I have 3 times to set up ox but every time i try this, i got different error messages.

        1. error
        Code:
        /opt/open-xchange/sbin/oxinstaller --oxdb-pass=mypass --admin-pass=mypass --maildomain wullbrandtundseele.de
        initializing database (step 1/2) done
        Configuring services
        setting readUrl in /opt/open-xchange/etc/admindaemon/configdb.properties
        setting writeUrl in /opt/open-xchange/etc/admindaemon/configdb.properties
        setting readProperty.1 in /opt/open-xchange/etc/admindaemon/configdb.properties
        setting readProperty.2 in /opt/open-xchange/etc/admindaemon/configdb.properties
        setting writeProperty.1 in /opt/open-xchange/etc/admindaemon/configdb.properties
        setting writeProperty.2 in /opt/open-xchange/etc/admindaemon/configdb.properties
        setting readUrl in /opt/open-xchange/etc/groupware/configdb.properties
        setting writeUrl in /opt/open-xchange/etc/groupware/configdb.properties
        setting readProperty.1 in /opt/open-xchange/etc/groupware/configdb.properties
        setting readProperty.2 in /opt/open-xchange/etc/groupware/configdb.properties
        setting writeProperty.1 in /opt/open-xchange/etc/groupware/configdb.properties
        setting writeProperty.2 in /opt/open-xchange/etc/groupware/configdb.properties
        (Re)Starting Admin Daemon done
        initializing database (step 2/2)Server response:
         java.sql.SQLException: Server connection failure during transaction. Due to underlying exception: 'java.sql.SQLException: Access denied for user 'openexchange'@'localhost' (using password: YES)'.
        
        ** BEGIN NESTED EXCEPTION ** 
        
        java.sql.SQLException
        MESSAGE: Access denied for user 'openexchange'@'localhost' (using password: YES)
        
        STACKTRACE:
        
        java.sql.SQLException: Access denied for user 'openexchange'@'localhost' (using password: YES)
                at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:2975)
                at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:798)
                at com.mysql.jdbc.MysqlIO.secureAuth411(MysqlIO.java:3715)
                at com.mysql.jdbc.MysqlIO.doHandshake(MysqlIO.java:1203)
                at com.mysql.jdbc.Connection.createNewIO(Connection.java:2693)
                at com.mysql.jdbc.Connection.<init>(Connection.java:1485)
                at com.mysql.jdbc.NonRegisteringDriver.connect(NonRegisteringDriver.java:266)
                at java.sql.DriverManager.getConnection(DriverManager.java:525)
                at java.sql.DriverManager.getConnection(DriverManager.java:171)
                at com.openexchange.admin.tools.AdminCacheExtended.getSimpleSqlConnection(AdminCacheExtended.java:178)
                at com.openexchange.admin.storage.mysqlStorage.OXContextMySQLStorage.createDatabase(OXContextMySQLStorage.java:741)
                at com.openexchange.admin.storage.mysqlStorage.OXContextMySQLStorage.create(OXContextMySQLStorage.java:382)
                at com.openexchange.admin.rmi.impl.OXContextLightImpl.create(OXContextLightImpl.java:98)
                at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
                at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
                at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
                at java.lang.reflect.Method.invoke(Method.java:585)
                at sun.rmi.server.UnicastServerRef.dispatch(UnicastServerRef.java:294)
                at sun.rmi.transport.Transport$1.run(Transport.java:153)
                at java.security.AccessController.doPrivileged(Native Method)
                at sun.rmi.transport.Transport.serviceCall(Transport.java:149)
                at sun.rmi.transport.tcp.TCPTransport.handleMessages(TCPTransport.java:466)
                at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.run(TCPTransport.java:707)
                at java.lang.Thread.run(Thread.java:595)
        
        
        ** END NESTED EXCEPTION **
        
        
        Attempted reconnect 3 times. Giving up.
         done
        2. error
        Code:
         ant -Dlib.dir=/opt/open-xchange/lib/ -lib /opt/open-xchange/lib deploy
        Buildfile: build.xml
        
        css:
             [xslt] DEPRECATED - xalan processor is deprecated. Use trax instead.
             [xslt] DEPRECATED - xslp processor is deprecated. Use trax instead.
             [xslt] java.lang.ClassNotFoundException: org.apache.tools.ant.taskdefs.optional.XslpLiaison
             [xslt]     at java.net.URLClassLoader$1.run(URLClassLoader.java:200)
             [xslt]     at java.security.AccessController.doPrivileged(Native Method)
             [xslt]     at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
             [xslt]     at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
             [xslt]     at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
             [xslt]     at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:319)
             [xslt]     at java.lang.Class.forName0(Native Method)
             [xslt]     at java.lang.Class.forName(Class.java:164)
             [xslt]     at org.apache.tools.ant.taskdefs.XSLTProcess.loadClass(XSLTProcess.java:419)
             [xslt]     at org.apache.tools.ant.taskdefs.XSLTProcess.resolveProcessor(XSLTProcess.java:397)
             [xslt]     at org.apache.tools.ant.taskdefs.XSLTProcess.getLiaison(XSLTProcess.java:619)
             [xslt]     at org.apache.tools.ant.taskdefs.XSLTProcess.execute(XSLTProcess.java:212)
             [xslt]     at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:275)
             [xslt]     at org.apache.tools.ant.Task.perform(Task.java:364)
             [xslt]     at org.apache.tools.ant.Target.execute(Target.java:341)
             [xslt]     at org.apache.tools.ant.Target.performTasks(Target.java:369)
             [xslt]     at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1216)
             [xslt]     at org.apache.tools.ant.Project.executeTarget(Project.java:1185)
             [xslt]     at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:40)
             [xslt]     at org.apache.tools.ant.Project.executeTargets(Project.java:1068)
             [xslt]     at org.apache.tools.ant.Main.runBuild(Main.java:668)
             [xslt]     at org.apache.tools.ant.Main.startAnt(Main.java:187)
             [xslt]     at org.apache.tools.ant.launch.Launcher.run(Launcher.java:246)
             [xslt]     at org.apache.tools.ant.launch.Launcher.main(Launcher.java:67)
             [xslt] java.lang.ClassNotFoundException: org.apache.tools.ant.taskdefs.optional.XalanLiaison
             [xslt]     at java.net.URLClassLoader$1.run(URLClassLoader.java:200)
             [xslt]     at java.security.AccessController.doPrivileged(Native Method)
             [xslt]     at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
             [xslt]     at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
             [xslt]     at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
             [xslt]     at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:319)
             [xslt]     at java.lang.Class.forName0(Native Method)
             [xslt]     at java.lang.Class.forName(Class.java:164)
             [xslt]     at org.apache.tools.ant.taskdefs.XSLTProcess.loadClass(XSLTProcess.java:419)
             [xslt]     at org.apache.tools.ant.taskdefs.XSLTProcess.resolveProcessor(XSLTProcess.java:402)
             [xslt]     at org.apache.tools.ant.taskdefs.XSLTProcess.getLiaison(XSLTProcess.java:616)
             [xslt]     at org.apache.tools.ant.taskdefs.XSLTProcess.execute(XSLTProcess.java:212)
             [xslt]     at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:275)
             [xslt]     at org.apache.tools.ant.Task.perform(Task.java:364)
             [xslt]     at org.apache.tools.ant.Target.execute(Target.java:341)
             [xslt]     at org.apache.tools.ant.Target.performTasks(Target.java:369)
             [xslt]     at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1216)
             [xslt]     at org.apache.tools.ant.Project.executeTarget(Project.java:1185)
             [xslt]     at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:40)
             [xslt]     at org.apache.tools.ant.Project.executeTargets(Project.java:1068)
             [xslt]     at org.apache.tools.ant.Main.runBuild(Main.java:668)
             [xslt]     at org.apache.tools.ant.Main.startAnt(Main.java:187)
             [xslt]     at org.apache.tools.ant.launch.Launcher.run(Launcher.java:246)
             [xslt]     at org.apache.tools.ant.launch.Launcher.main(Launcher.java:67)
        
        BUILD FAILED
        /tmp/open-xchange-gui/build.xml:57: java.lang.ClassNotFoundException: org.apache.tools.ant.taskdefs.optional.TraXLiaison
        
        Total time: 0 seconds
        root@wullbrandtundseele:/tmp/open-xchange-gui#
        Then there is a bug report here:
        http://www.open-xchange.org/bugzilla...ug.cgi?id=6344
        But sorry, what does Frederic Beuserie in message 6 mean? I dont know what to do now.

        Comment


        • #34
          Checkout this posting http://typo3.open-xchange.com/forum/...hp?t=16&page=4

          Comment

          Working...
          X