Announcement

Collapse
No announcement yet.

Connection Error when trying to access OX AppSuite

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Connection Error when trying to access OX AppSuite

    Hello,

    I already installed and succesfully configured OpenXchange Server, and now I try to run the OpenXchange AppSuite. I installed it succesfully, but when I try to login it gives me this error : "Connection error. The service is not available right now. Retry". I mention that I already have the user e-mail accounts configured with authentication database.
    Can you help me to use also the OX AppSuite with these accounts ?

    Thanks!

  • #2
    You have the OX6 frontend running already?

    In that case it might be that Apache is not configured for App Suite frontend. The error at least looks like the frontend has issues talking to the backend which most likely misses some Apache configuration _if_ OX6 frontend is running correctly.
    Otherwise it could be anything and you would need to provide more information.

    Comment


    • #3
      Yes, I have OX6 version 6.22 installed and running.
      I configured apache like in the documentation, with another VirtualHost (with other IP than VirtualHost for OX Server) like that:
      [root@oxa ~]# cat /etc/httpd/conf.d/oxapp.conf
      <VirtualHost oxapp.copeland.ro:80>
      ServerAdmin daniel@copeland.ro
      ServerName oxapp.copeland.ro
      DocumentRoot /var/www/html/
      <Directory /var/www/html/>
      Options Indexes FollowSymLinks MultiViews
      AllowOverride None
      Order allow,deny
      allow from all
      RedirectMatch ^/$ /appsuite/
      </Directory>

      <Directory /var/www/html/appsuite>
      Options None +SymLinksIfOwnerMatch
      AllowOverride Indexes FileInfo
      </Directory>

      ErrorLog /var/log/httpd/oxapp_error.log

      # Possible values include: debug, info, notice, warn, error, crit,
      # alert, emerg.
      LogLevel warn

      CustomLog /var/log/httpd/oxapp_access.log combined
      </VirtualHost>

      I need to change other thinks ?

      Thanks!

      Comment


      • #4
        The proxy_ajp.conf is the more interesting one.
        Does it contain everything mentioned in the documentation?

        Comment


        • #5
          Hello,

          Yes, it includes this :

          <Location /webservices>
          # restrict access to the soap provisioning API
          Order Deny,Allow
          Deny from all
          Allow from 127.0.0.1
          Allow from 10.20.30
          Allow from 192.168.45
          # you might add more ip addresses / networks here
          # Allow from 192.168 10 172.16
          </Location>
          # the old path is kept for compatibility reasons
          <Location /servlet/axis2/services>
          # restrict access to the soap provisioning API
          Order Deny,Allow
          Deny from all
          Allow from 127.0.0.1
          Allow from 10.20.30
          Allow from 192.168.45
          # you might add more ip addresses / networks here
          # Allow from 192.168 10 172.16
          </Location>

          <IfModule mod_proxy_ajp.c>
          ProxyRequests Off
          <Proxy balancer://oxcluster>
          Order deny,allow
          Allow from all
          # multiple server setups need to have the hostname inserted instead localhost
          BalancerMember ajp://localhost:8009 timeout=100 smax=0 ttl=60 retry=60 loadfactor=50 route=OX1
          # Enable and maybe add additional hosts running OX here
          # BalancerMember ajp://oxhost2:8009 timeout=100 smax=0 ttl=60 retry=60 loadfactor=50 route=OX2
          ProxySet stickysession=JSESSIONID
          </Proxy>
          <Proxy /ajax>
          ProxyPass balancer://oxcluster/ajax
          </Proxy>
          <Proxy /servlet>
          ProxyPass balancer://oxcluster/servlet
          </Proxy>
          <Proxy /infostore>
          ProxyPass balancer://oxcluster/infostore
          </Proxy>
          <Proxy /publications>
          ProxyPass balancer://oxcluster/publications
          </Proxy>
          <Proxy /Microsoft-Server-ActiveSync>
          ProxyPass balancer://oxcluster/Microsoft-Server-ActiveSync
          </Proxy>
          <Proxy /usm-json>
          ProxyPass balancer://oxcluster/usm-json
          </Proxy>
          <Proxy /webservices>
          ProxyPass balancer://oxcluster/webservices
          </Proxy>
          ProxyPass /Microsoft-Server-ActiveSync ajp://127.0.0.1:8009/Microsoft-Server-ActiveSync smax=0 ttl=60 retry=5
          </IfModule>

          Comment


          • #6
            Please compare with
            http://oxpedia.org/wiki/index.php?ti...igure_services

            Especially
            <Proxy /appsuite/api>
            ProxyPass balancer://oxcluster/ajax
            </Proxy>
            seems to be missing.

            Comment


            • #7
              or this one: http://oxpedia.org/wiki/index.php?ti...ite_Debian_6.0
              Markus Wagner
              Open-Xchange Quality Assurance

              Comment


              • #8
                Hello,
                I changed it after the note what you tell me about but I still have the error. I restarted the http server and open-xchange. Now I have this configuration for proxy_html.conf :
                <IfModule mod_proxy_ajp.c>
                ProxyRequests Off
                <Proxy balancer://oxcluster>
                Order deny,allow
                Allow from all
                # multiple server setups need to have the hostname inserted instead localhost
                BalancerMember ajp://localhost:8009 timeout=100 smax=0 ttl=60 retry=60 loadfactor=50 route=OX1
                # Enable and maybe add additional hosts running OX here
                # BalancerMember ajp://oxhost2:8009 timeout=100 smax=0 ttl=60 retry=60 loadfactor=50 route=OX2
                ProxySet stickysession=JSESSIONID
                </Proxy>

                # OX AppSuite frontend
                <Proxy /appsuite/api>
                ProxyPass balancer://oxcluster/ajax
                </Proxy>

                # OX6 / Mobile Webinterface frontends
                <Proxy /ajax>
                ProxyPass balancer://oxcluster/ajax
                </Proxy>
                <Proxy /servlet>
                ProxyPass balancer://oxcluster/servlet
                </Proxy>
                <Proxy /infostore>
                ProxyPass balancer://oxcluster/infostore
                </Proxy>
                <Proxy /publications>
                ProxyPass balancer://oxcluster/publications
                </Proxy>

                # USM
                <Proxy /usm-json>
                ProxyPass balancer://oxcluster/usm-json
                </Proxy>

                # SOAP
                <Proxy /webservices>
                ProxyPass balancer://oxcluster/webservices
                </Proxy>

                # OXtender
                <Proxy /Microsoft-Server-ActiveSync>
                ProxyPass balancer://oxcluster/Microsoft-Server-ActiveSync
                </Proxy>
                ProxyPass /Microsoft-Server-ActiveSync ajp://127.0.0.1:8009/Microsoft-Server-ActiveSync smax=0 ttl=60 retry=5
                </IfModule>

                Thanks!

                Comment


                • #9
                  Hi,

                  did you install open-xchange-ajp or open-xchange-grizzly?

                  Cheers
                  Martin

                  Comment


                  • #10
                    Yes, I have already installed open-xchange-ajp, but when I try to install open-xchange-grizzly it shows me this errror :
                    Error: open-xchange-grizzly conflicts with open-xchange-ajp-7.2.0-4_5.1.noarch

                    Thanks!

                    Comment


                    • #11
                      Well, that's because you can only chose one: ajp provides an AJP backend for OX, grizzly provides a HTTP backend to ox. They can be used by mod_proxy_ajp or mod_proxy_http respectively. My guess was that you're running a HTTP backend but configured an AJP frontend in Apache.

                      Is there anything at the Apache error log when trying to log in? Are you using a distributed setup (separate Apache, OX machines)? Any error logged when inspecting the login process with Firebug?

                      Comment


                      • #12
                        Hello,

                        I don't see any errors in apache error_log. What I see is in access.log :
                        10.20.30.1 - - [20/Jun/2013:12:22:07 +0300] "GET /appsuite/api/apps/load/v=7.2.1-3.20130527.074101,io.ox/core/http.js,io.ox/core/session.js,io.ox/core/cache.js,io.ox/core/extensions.js,io.ox/core/manifests.js,io.ox/core/capabilities.js,io.ox/core/config.js,io.ox/core/settings.js,io.ox/core/event.js,io.ox/core/cache/indexeddb.js,io.ox/core/cache/localstorage.js,io.ox/core/cache/simple.js,io.ox/core/async.js,/text;io.ox/core/bootstrap/css/bootstrap.less HTTP/1.1" 404 244 "-" "Opera/9.80 (Windows NT 5.1) Presto/2.12.388 Version/12.15"

                        Also I don't see any error neither in open-xchange.log and open-xchange-console.log
                        I have on one machine the ox server, apache and mysql.
                        All that I see in the ox app webpage is : Connection error The service is not available right now. Retry

                        You have right. I configured to use ajp wih mod_proxy_ajp. This works very good with OX server, but with OX app I see that something is wrong.

                        Thanks!

                        Comment

                        Working...
                        X