Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 8 of 8
  1. #1
    Join Date
    Jul 2010
    Posts
    14

    Question attachment upload fails

    on our ox we can not upload any attachments.

    we get this error:

    Fehlermeldung: Hochladen der Datei fehlgeschlagen: Processing of multipart/form-data request failed. /tmp/.OX/upload__xxx.tmp (no such file or directory) (UPL-0001, 585025325-10537)

    /tmp directory exists and is writable :
    drwxrwxrwt 5 root root 4096 3. Aug 22:43 tmp

    but there is no .OX directory in there !?

    any hints on this ?

  2. #2
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    could you try to create the .OX directory manually? Does that help?
    If it only occurs for specific files, please post the whole stack trace from open-xchange.log

    Greetings

  3. #3
    Join Date
    Jul 2010
    Posts
    14

    Default

    after the manual creation of the .OX folder it works!

    why does ox not create it ?

  4. #4
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    I'm not sure why it did not work on your system - what operating system and OX version are you using? The folder is created during installation, perhaps the permissions were not correct at this point?

  5. #5
    Carsten Hoeger is offline Open-Xchange Professional Services
    Join Date
    Mar 2007
    Posts
    703

    Default

    Some systems have settings where /tmp is cleaned automatically via cronjob per default.
    Please check that on your system.
    AFAIR RHEL5 has such a default, I'm not sure, though.
    OXpedia.org - the answer to almost all questions.

  6. #6
    Join Date
    Jul 2010
    Posts
    14

    Default

    the system is centos

    ox and centos are both on the newest version

  7. #7
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Okay, since CentOS is a RedHat derivate, it also comes with a "tmpcleanup" cronjob:
    http://www.mail-archive.com/centos@c.../msg05623.html

    You could either disable this job, rewrite it to keep .OX or use another temporary location for file uploads.

    Greetings

  8. #8
    Join Date
    Jul 2010
    Posts
    14

    Default

    ok, thank you very mutch!

    i will change the cronjob...

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •